Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Reverse lights don't work in MT

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 87K54WD, Mar 23, 2000.

  1. 87K54WD

    87K54WD 1/2 ton status

    Joined:
    Mar 23, 2000
    Posts:
    105
    Likes Received:
    0
    Location:
    Texas
    Reverse lights don\'t work in MT

    My reverse lights don't work when I put the MT in reverse. I'm looking to get this fixed tomorrow at a GM dealership. I got this truck from my uncle and he believes that it stopped working after getting the MT serviced with a new clutch. Did the shop forget to put a wiring harness back together? Any help is greatly appreciated. I would like to try to fix it myself tonight if possible. Checked the fuse and bulbs and they are fine. Any idesas on how much the dealership might charge me? Any ideas/advice/suggestions on the fix? Thanks
     
  2. Goose

    Goose 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,127
    Likes Received:
    1
    Location:
    South Central Kansas
    Re: Reverse lights don\'t work in MT

    There should be two wires in the engine compartment that go to the transmission reverse switch. I believe it will be on top of the tranny and come up closer to the passenger side. The wires will be dark blue and light green.
     
  3. 6.2 man

    6.2 man 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    636
    Likes Received:
    1
    Location:
    Curtis , WA
    Re: Reverse lights don\'t work in MT

    Find the connector on the transmission switch and use a jumper wire to connect them together . If they work the switch is bad . If not check one side of connector to see if it's hot . If it is than sounds like bad wiring or bad bulbs .
     

Share This Page