Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Ride Problem....HELP!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by vdubbin86, May 28, 2002.

  1. vdubbin86

    vdubbin86 Registered Member

    Joined:
    May 25, 2002
    Posts:
    55
    Likes Received:
    0
    Location:
    Alberta, Canada
    I got some major bumpsteer going on with my truck. Today on my way home from work I went over a little dip in the road and the truck took off to the right.(Almost lost it cause I wasn't expecting it) It bounces around alot over small bumps also. God forbid if I ever went over some uneven tracks at any speed, I'd probably end up in the ditch on my roof.

    Any common problems that these trucks have with this? I have a stab but it is probably getting pretty worn out.(Looks pretty old, but not leaking) Would replacing this help??? Or a double one???

    There isn't a swaybar on it either. I'm guessing it came with one from the factory but was removed before I got my hands on it. Should I go to the local boneyard and find one for it?

    It's an 81 K10, 10/12 bolt, 4" lift with springs in the front and blocks in the rear, riding on 33" Hankooks if that helps with the answers.

    Thanks
     
  2. mudhog

    mudhog THEGAME Staff Member Super Moderator

    Joined:
    Nov 6, 2000
    Posts:
    17,899
    Likes Received:
    2
    Location:
    portland oregon
    if you need a sway bar i have one id sell for $20 plus shipping /forums/images/icons/smile.gif
     
  3. 70~K5

    70~K5 1/2 ton status

    Joined:
    Apr 13, 2002
    Posts:
    2,032
    Likes Received:
    0
    Location:
    sillycon valley
    Do you have a raised steering arm on the left knuckle? When sitting still is your draglink flat or running down to the knuckle?
     
  4. vdubbin86

    vdubbin86 Registered Member

    Joined:
    May 25, 2002
    Posts:
    55
    Likes Received:
    0
    Location:
    Alberta, Canada
    The draglink is flat. I grabbed it and gave it a good shake and no play. Front end seems tight.Bushings in the front springs look like new. And all tires are at 32psi.

    Thanks
     
  5. vdubbin86

    vdubbin86 Registered Member

    Joined:
    May 25, 2002
    Posts:
    55
    Likes Received:
    0
    Location:
    Alberta, Canada
    I could probably get one at a boneyard for the price of shipping alone. But thanks anyway. /forums/images/icons/smile.gif
     
  6. rampage

    rampage 1/2 ton status

    Joined:
    Mar 20, 2001
    Posts:
    2,259
    Likes Received:
    72
    Location:
    Humboldt/Pacifica, CA
    Wouldn't worn ball joints cause bad steering too? Just a thought ...
     
  7. mudhog

    mudhog THEGAME Staff Member Super Moderator

    Joined:
    Nov 6, 2000
    Posts:
    17,899
    Likes Received:
    2
    Location:
    portland oregon
    probably true just thought id offer /forums/images/icons/smile.gif
     

Share This Page