Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

rough idle

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by nc87k5, Oct 16, 2003.

  1. nc87k5

    nc87k5 3/4 ton status

    Joined:
    Sep 23, 2003
    Posts:
    5,231
    Likes Received:
    0
    Location:
    North Carolina
    my 87 has the TBI and when I first crank it, the idle seems to be rough, it will idle high then low like it is going to cut off. I have already replaced the idle air control valve but that hasn't seemed to help. Any suggestions?
     
  2. 99firehawk

    99firehawk 1/2 ton status

    Joined:
    Dec 15, 2002
    Posts:
    491
    Likes Received:
    0
    the gasket between the tbi and the intake, very very common I must have done 2-3 in the 2 years i had my tbi van.
     
  3. jpaitala

    jpaitala Registered Member

    Joined:
    Sep 1, 2003
    Posts:
    33
    Likes Received:
    0
    Location:
    Imatra, Finland
    On my '89 TBI the problem was the MAP-sensor, after I replaced that the rough idle problem was solved. Cheap part, easy/fast to change.
     
  4. Thunder

    Thunder 3/4 ton status

    Joined:
    Jul 20, 2000
    Posts:
    8,946
    Likes Received:
    1
    Location:
    Northeast Nevada
    Have you checked for trouble codes? You should always do that first before you start throwing parts at it.
     
  5. jpaitala

    jpaitala Registered Member

    Joined:
    Sep 1, 2003
    Posts:
    33
    Likes Received:
    0
    Location:
    Imatra, Finland
    Yes, definately check the codes first.
    I got no codes when I had that rough idle mystery and changing the MAP-sensor solved the problem.
     

Share This Page