Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

run on??

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by NoSmog73, Nov 18, 2001.

  1. NoSmog73

    NoSmog73 1/2 ton status

    Joined:
    Sep 28, 2001
    Posts:
    2,348
    Likes Received:
    0
    Location:
    lodi,ca
    Hello again here is my problem when I turn the engine stock 350 off sometimes it will studder as it shuts off or idle on. So to stop that I have been turning off the ignition off in gear ??????????? any thoughts.I have new plugs,cap,rotor,wires,new accellerater pump,fuel filter,all the standard tune-up stuff.
     
  2. Can Can

    Can Can Pusher Man Staff Member Super Moderator

    Joined:
    Feb 17, 2000
    Posts:
    15,555
    Likes Received:
    156
    Location:
    Cochrane, Alberta, Canada
    I believe that if your timing is too far advanced it can cause your engine to diesel or run-on after it's shut off. Might be worth it to recheck your timing........



    <font color=blue> NEVER FORGET, NEVER FORGIVE, NEVER SURRENDER<font color=blue>
     
  3. DesertDueler

    DesertDueler 1/2 ton status

    Joined:
    May 23, 2001
    Posts:
    3,106
    Likes Received:
    0
    Location:
    Phoenix, AZ
    Its either timing or its idle. If you idle is to high it will do this also. I have that problem in my firebird. I have the idle so its 1000 in gear and 1200 in park so it will idle. If I shut it off in park it runs on if I shut it off in gear it is fine. Lower your idle 100 rpms and see if it goes away.

    86Jimmy 4"&35"MTRs,87 burb 4"&35"MT,69Firebird w/525 hp,and 70GTO live in PHX,AZ<a target="_blank" href=http://www.geocities.com/modifierperformance>My vehicles</a>
     
  4. NoSmog73

    NoSmog73 1/2 ton status

    Joined:
    Sep 28, 2001
    Posts:
    2,348
    Likes Received:
    0
    Location:
    lodi,ca
    thanks juat had to take back my new tach so I will put it back in tommorow -thanks
     
  5. Sparky

    Sparky 1/2 ton status

    Joined:
    Aug 20, 2000
    Posts:
    423
    Likes Received:
    0
    Location:
    San Antonio(summer) Texas A and M (school year)
    Also, if you engine is running rich it will build up carbon depositis in the combustion chambers. Those carbon deposits act kind of like glow plugs in a diesel. They stay hot enough to ignite the fuel even after the ignition has shut off thus the engine trys to keep running. That opens up a whole cam of worms including timeing, maybe some bad plugs, carberator, etc.


    Sparky

    When all else fails... Check the blinker fluid.
    78 K-5
     
  6. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,982
    Likes Received:
    191
    Location:
    Roy WA
    If this is your 73, it won't apply, but my '83 with AC (assuming it was for AC, could care less, ditched it) had a kickup(?) solenoid for the AC on it, and it started to fail, so that when I shut the truck off, it forced the throttle open more, and it kept running. Unplugging the solenoid fixed the problem.

    Dorian
    My tech/links page: <a target="_blank" href=http://www.dorianyeager.com/index2.html>www.dorianyeager.com/index2.html</a>
    Why insist on counting when the ring gear has the tooth counts stamped in?
     

Share This Page