Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

RYAN!! I have a question, and it says you dont want PMs.

Discussion in 'The Lounge' started by K5MONSTERCHEV, Feb 22, 2005.

  1. K5MONSTERCHEV

    K5MONSTERCHEV 1/2 ton status

    Joined:
    Jan 27, 2003
    Posts:
    3,254
    Likes Received:
    0
    Location:
    Castro Valley, CA
    OH Ryan B that is. What was the deal with your knock sensor? What were the incorrect and correct PNs for the computer? Your write up isnt there anymore. Thanks man.

    Greg
     
  2. Ryan B.

    Ryan B. 3/4 ton status GMOTM Winner

    Joined:
    Jul 18, 2001
    Posts:
    5,693
    Likes Received:
    0
    Location:
    CA
    WTF? I don't want pms? hmm.. maybe i need to delete a couple hundred of my pms to make some room. :grin:

    My tpi write up is still in the tech articles (advanced previews) members forum...

    The answer to your question..
    The knock sensor I had was # 10456289 and Not # 10456549 which is what I needed to function correctly with my ecm # 122730!
    I was getting a knock sensor trouble code and timing error trouble code and it idled but ran all chitty when i'd get on it. once i put in the correct knock sensor and re-timed the engine it ran perfect. :thumb:
    Another thing, when i was in pismo a year ago, my knock sensor wire came loose and bounced onto the header where it melted the insulation and was shorting out that wire to ground.. all of a sudden i had a check engine light and i could feel the computer pulling a LOT of timing outta the engine.. it had No power. When i popped the hood i found that wire up against the headers.. i taped the wire where the insulation was melted, and ziptied it up so it won't happen again. unplugged my ecm to clear the code, and i've never gotten a trouble code since.
     
  3. K5MONSTERCHEV

    K5MONSTERCHEV 1/2 ton status

    Joined:
    Jan 27, 2003
    Posts:
    3,254
    Likes Received:
    0
    Location:
    Castro Valley, CA
    Woah, ok it is, I looked the other day and didnt see it..oops. :crazy:

    Anyway. Thanks for reposting it. It seems I have the correct knock sensor. Before I had NO knock signal and NO timing retard, so I checked the wire and the harness back to the comp was fine, checked the knock sensor, it was working. I realized it wasnt sending a signal to the computer because it wasnt groundng, due to the fact I put tape on the threads. I finally got it to ground and show a knock signal and timing retard, but now the light wont stay out. I clear the code, it comes right back. I was thinking I had the wrong knock sensor, but that doesnt seem to be the case. The flow chart says the Mem Cal is bad, but I dont think its the chip. I should just take it to the dealer, lol.:D

    Oh yeah the pismo thing sucks. I routed mine so it hopefully wont hit the header.
     
  4. Ryan B.

    Ryan B. 3/4 ton status GMOTM Winner

    Joined:
    Jul 18, 2001
    Posts:
    5,693
    Likes Received:
    0
    Location:
    CA
    The pismo thing is going on memorial day weekend. Last weekend of may. Better make reservations now before it fills up!

    I hear theres a 4x4 event at the pleasanton fairgrounds this weekend.. with a rock course.. some of the club guys are trying to peer pressure me into entering my truck in the event. :grin: You gonna run it? :p:
     
  5. K5MONSTERCHEV

    K5MONSTERCHEV 1/2 ton status

    Joined:
    Jan 27, 2003
    Posts:
    3,254
    Likes Received:
    0
    Location:
    Castro Valley, CA
    I have been hearing it on the radio, but I didnt know it was this weekend and I think its the, umm, sportsman expo, or something, with a rock crawiling course presented by 4 Wheel Parts. You should though. Am I going to? In 2wd? Yeah sure, no. Im working on my truck still anyway.

    So everything works, it senese knock, it retards, but now the light wont go out. Also, the seal at the back of the steering box leaks, before it wasnt bad, now it leaks while its sitting!! That needs to get fixed ASAP!

    Pismo, ill keep that open.
     

Share This Page