Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Sending unit intermittent

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by unsane, Jan 1, 2003.

  1. unsane

    unsane Guest

    Anyone else have a fuel sending unit problem? have an 89 and sometimes I will start the truck up and the fuel gauge will read correct, the next time I go out the fuel gauge says empty. All this causes mass hysteria while driving because I dont want to run out of gas out in B.F.E. where I live. The coyotes will get me. Just wondering if I could pull the tank and fix this or if it might be an electrical short or what? Thanks -Eric
     
  2. Batmanjr

    Batmanjr 1/2 ton status

    Joined:
    Mar 23, 2001
    Posts:
    1,537
    Likes Received:
    0
    Location:
    Copperas Cove, Texas
    Check wires! If it is interemitent, then more than likely you have a lose connection! If it is the sending unit itself, start looking for a doner!!!! They cost $300 from Chevy and they're the only one that carry them!
     
  3. Chris87K5

    Chris87K5 1/2 ton status

    Joined:
    Sep 21, 2002
    Posts:
    322
    Likes Received:
    0
    Location:
    Pennsyltucky
    I got a new one from Advanced Auto for $219
    It runs alot better now and my fuel gauge works correctly. /forums/images/graemlins/thumb.gif
     
  4. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    $300???? I was about to replace mine, but for that much it works just fine...
     

Share This Page