Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Serptine Belt bracket rattle?... help!

Discussion in 'The Garage' started by eclipse, Jul 20, 2006.

  1. eclipse

    eclipse 1/2 ton status

    Joined:
    Jan 1, 2005
    Posts:
    1,245
    Likes Received:
    0
    Location:
    Sparks, NV
    89 Suburban...

    Ok first I thought it was my actaully A/C pump that was vibrating at an idle so I replaced it... didn't change a thing. I noticed the bolt holding the braces behind the idler puller wasn't tightened, it was stripped out in the bracket. So then I started the burb up with the A/C on and when the vibration started, I put my hand on the A/c pump and put pressure on it and the vibration stopped. So I got a new passenger side housing that holds the A/C pump and the idler pulley... well CRAP! I can't get it off, it has a weird bolt head on one of the bolts holding it to the head that I haven't ever seen before and I dont have a socket to take it off. I can't see any more damage to the housing where it could be causing the vibration... Also on the bottom of the bracket there is two bolt holes, are there suppose to be bolts down there holding the housing on? Ugh I dont know what to do, I have a road trip across the state tomorrow and I want the vibration gone so I can use my A/C

    072006_2051.jpg

    072006_2052.jpg
     
  2. readymix

    readymix 3/4 ton status

    Joined:
    May 30, 2004
    Posts:
    6,706
    Likes Received:
    26
    Location:
    Murrieta, California
    Can't see too much form the pics and I don;t have AC to compare it to.....but it looks to be an allen.
     
  3. eclipse

    eclipse 1/2 ton status

    Joined:
    Jan 1, 2005
    Posts:
    1,245
    Likes Received:
    0
    Location:
    Sparks, NV
    well frustating... haha I thought I took higher resolution pictures. My housing appears to be fine. I thought it was cracked, I was able to dig up a bolt out of my tool box to put in the bottom of the of the housing. I put it back together and the vibration is gone... ugh this has been fun. Atleast its back together for my trip tomorrow.
     
  4. mouse

    mouse 1/2 ton status

    Joined:
    Nov 10, 2003
    Posts:
    1,448
    Likes Received:
    0
    Location:
    Great Falls Mt
    There should be one nut/stud combo holding the bracket to the head. The rest are just standard bolts.
     

Share This Page