Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

service engine soon....?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Kelboski, Mar 16, 2000.

  1. Kelboski

    Kelboski 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    306
    Likes Received:
    0
    Location:
    Mcdonough,Ga
    my 90 k5 has a new 350 w/ 10 k miles. my problem is when i give it good gas on the highway, it seems to bog down and sometimes the service engine soon light comes on. i just changed the 02 sensor last monday thinking it was the problem, but it still does it. the light goes off when i cut the engine off, and it does'nt come back on until i juice it again. it does'nt always come on, but very often it does. it seems to be running rich too. any suggestions? i'm frustrated...please help......what should i do next. maybe the egr valve?...please help
    thanks...Kelboski
     
  2. **b**

    **b** 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    279
    Likes Received:
    0
    Location:
    KIllington, VT.
    My old 87MonteSS did that...
    So i sold it.
     
  3. Eagle86K5

    Eagle86K5 1/2 ton status

    Joined:
    Mar 5, 2000
    Posts:
    974
    Likes Received:
    0
    Location:
    Whitehouse, Ohio
    unhook one of the battery cables, wait a minute then put it back on. What this dies is cause the computer to reset itself. I have known this to cause the service engine light to extinguish till something causes it to come on naturally. Otherwise get a reader and hook it up and read the codes. They will tell you where to look. Good luck...

    <font color=green>Eagle86K5[​IMG]

    <font color=red>Only guy I know that can get out of line in a one car funeral
     
  4. 89Jimmy

    89Jimmy 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    192
    Likes Received:
    0
    Location:
    Northern N.Y. east end of Lake Ontario
    There is a black terminal block on my 89 under the dash to the left of the steering column. The terminal strip is 6 wide and 2 rows high. The terminals are all empty. Use a U-shaped piece of wire and connect the 2 terminals on the upper row,farthest right,(ignition off when you connect) After connecting, turn on the ignition, don't start the truck. The ses light should flash a single time and then twice. It will do this 3 times. The pattern represents the # twelve. This is normal. After the three times, another pattern should flash, this one(or more)will represent the problems stored in the computer. 32 is egr. 44 is lean condition, etc. You can buy a service manual at the parts store that will have the codes, or a public library might have it. If you re-post here we can also hook you up. Best of luck.
    John
     

Share This Page