Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Shaking in OD

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by FL84K5, Oct 22, 2001.

  1. FL84K5

    FL84K5 1/2 ton status

    Joined:
    Aug 19, 2001
    Posts:
    936
    Likes Received:
    0
    Location:
    Sarasota, FL
    I have an '84 Blazer with an automatic tranny and 305. This morning, when I put the truck into OD it started to shake until I let off the gas. This afternoon I put it into overdrive again to see if it would do it and it didn't. What would cause this? Thanks
     
  2. MudFrog

    MudFrog 1/2 ton status

    Joined:
    Feb 23, 2000
    Posts:
    3,236
    Likes Received:
    0
    Location:
    Daleville, Va
    I had that problem and it was a bad tranny mount. Might just wanna check yours.

    89 K5 Silverado
    <a target="_blank" href=http://mudfrog.rockcrawler.com>http://mudfrog.rockcrawler.com</a>
     
  3. FL84K5

    FL84K5 1/2 ton status

    Joined:
    Aug 19, 2001
    Posts:
    936
    Likes Received:
    0
    Location:
    Sarasota, FL
    If it does end up being a bad mount, how hard are those to replace? ShouldI just get a stock replacement mount, or does a company like Energy Suspension make upgraded mounts? The truck does not shake in drive, only in OD.

    <P ID="edit"><FONT class="small">Edited by FL84K5 on 10/22/01 02:39 PM.</FONT></P>
     

Share This Page