Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

shifting issue

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 76_gmc, Apr 2, 2007.

  1. 76_gmc

    76_gmc Registered Member

    Joined:
    Feb 19, 2007
    Posts:
    30
    Likes Received:
    0
    Location:
    Enterprise, AL
    Stopped at an intersection, green light go....starts off like normal but won't automatically go up the gears. Stays in first. Auto transmission, fluid level good. linkage good.

    only thing i know is that the np208 has been leaking out the output seal and thats another story, if anyone can lead me in the right direction in getting one and replacing it, i have a slip yoke too.

    but the main issue....transmission won't shift up, i don't hear anything funny, smell anything....??????
     
  2. 76_gmc

    76_gmc Registered Member

    Joined:
    Feb 19, 2007
    Posts:
    30
    Likes Received:
    0
    Location:
    Enterprise, AL
    I got it!!! the dang transmission governor spline was worn....
     
  3. 99GmcClassic

    99GmcClassic Registered Member

    Joined:
    Mar 10, 2007
    Posts:
    97
    Likes Received:
    0
    Location:
    Abington, Mass
    Replace that t-case seal soon. If that fluid gets low the chain will stretch and eventually snap. Seal is cheap like 14.50 from the dealer, be careful when u remove the old one not to crack the tailshaft.
     

Share This Page