Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

slight backfire throught tbi

Discussion in 'The Garage' started by chvymudin3388, Jan 8, 2007.

  1. chvymudin3388

    chvymudin3388 1/2 ton status

    Joined:
    Mar 3, 2005
    Posts:
    374
    Likes Received:
    0
    Location:
    orange grove ,tx
    im getting a slight pop pop pop when i start it up and barely even rev it juist bump it and it goes popopop what is it? why is it doing it this... it also does it when warm sometimes
     
  2. Thunder

    Thunder 3/4 ton status

    Joined:
    Jul 20, 2000
    Posts:
    8,946
    Likes Received:
    1
    Location:
    Northeast Nevada
    Could be a number of things. Bad plug wires/cap rotor. When was your last tune up?
    Are the wires on in the right fireing order? Have you checked your timing?
    Are you getting any trouble codes?
    Could also be a stuck or burned valve.
    Bad timing chain and gears. How many miles on the engine?
     
  3. chvymudin3388

    chvymudin3388 1/2 ton status

    Joined:
    Mar 3, 2005
    Posts:
    374
    Likes Received:
    0
    Location:
    orange grove ,tx
    motor was recently rebuilt it has new sparkplugs new cap new rotor new pick up coil new coil new module new fuel pump the timing chain seemed to be in good shape though head job just done
     
  4. chevyguybc

    chevyguybc 1/2 ton status

    Joined:
    Nov 12, 2003
    Posts:
    524
    Likes Received:
    0
    Location:
    Vancouver Canada
    im having same problem with my s10 87 2.8 TBI

    it will run great, but then sometimes it will bog down and not rev up freely, and backfire through tbi unit
     
  5. Thunder

    Thunder 3/4 ton status

    Joined:
    Jul 20, 2000
    Posts:
    8,946
    Likes Received:
    1
    Location:
    Northeast Nevada
    If you recently had a head job. Check the valve adjustment. You may have a intake valve adjusted too tight.
     
  6. chvymudin3388

    chvymudin3388 1/2 ton status

    Joined:
    Mar 3, 2005
    Posts:
    374
    Likes Received:
    0
    Location:
    orange grove ,tx
    it only randomly does it under accerleration very little normally when cold it will like go pop pop pop when you accelerate and stop like three times most of the time or when you put a small load on it when its cold
     
  7. chvymudin3388

    chvymudin3388 1/2 ton status

    Joined:
    Mar 3, 2005
    Posts:
    374
    Likes Received:
    0
    Location:
    orange grove ,tx
    uhm i found out that my vacuum for my brakes to my intake is rather loose could this be causing my random popping?
     
  8. kwissman

    kwissman 1/2 ton status

    Joined:
    Jan 14, 2006
    Posts:
    118
    Likes Received:
    0
    Location:
    Austin, TX
    It could be a lean condition causing the backfire. Check your fuel pressure. The pump may be going out.
     
  9. Chaddy

    Chaddy 1/2 ton status GMOTM Winner

    Joined:
    May 23, 2005
    Posts:
    4,110
    Likes Received:
    2
    Location:
    Salt Lake City,Utah
    It sounds electrical. Even though you have new wires, 1 of them could be bad....I would spray the wires with a water/dishsoap solution and see...
     

Share This Page