Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Slipping

Discussion in 'The Garage' started by 87blues, Jan 23, 2006.

  1. 87blues

    87blues Registered Member

    Joined:
    Jun 2, 2005
    Posts:
    24
    Likes Received:
    0
    Location:
    Virginia
    Have an 87 Jimmy 4x4 that starting slipping yesterday while driving. Would get up to about 20 mph and it would just idle and only move cause it was coasting. I could shift down to 2nd on the automatic and it would run but of course could not do that long. I checked the fluid and it needed some. Put it in and it still does it. Any thoughts. Any bottle wonder to pour in that will fix it or is it needing rebuilt?
     
  2. trailblazr81

    trailblazr81 1/2 ton status

    Joined:
    May 27, 2005
    Posts:
    931
    Likes Received:
    0
    Location:
    Hollister, CA
    Try some Lucas oil. Heard people say tranny would slip and car wouldnt move, but after adding Lucas tranny additive worked fine. Tho I would think its near rebiuld time. Sorry.
     
  3. 87blues

    87blues Registered Member

    Joined:
    Jun 2, 2005
    Posts:
    24
    Likes Received:
    0
    Location:
    Virginia
    Thanks for the info. I will look into it. I can get this from any auto store right? Just the Tranny Lucas?
     
  4. trailblazr81

    trailblazr81 1/2 ton status

    Joined:
    May 27, 2005
    Posts:
    931
    Likes Received:
    0
    Location:
    Hollister, CA

Share This Page