Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

slooow accessories

Discussion in 'The Garage' started by bnc04, Dec 9, 2003.

  1. bnc04

    bnc04 Guest

    Hi, In my 350 TBI 88, I have noticed that the windows open and close more slowly than ever, Not just because it is colder as it has been happening since the early fall. In addition the wipers seem to be slower than normal.
    The Alt is the original and the battery is a couple years old. Before I go and start getting things tested, anybody run into this before? Oh and this is the scenario whether the engine is running or not. The back window has long lost the ability to open and close via the key in the back but the cab control works fine but this is where the slowness both up and down is really noticable.
    Thoughts? Thanks
    Brett
     
  2. Greg72

    Greg72 "Might As Well..." Staff Member Super Moderator

    Joined:
    Mar 5, 2001
    Posts:
    15,683
    Likes Received:
    1,392
    Location:
    642 Days to BB2018
    Since it's common to all accessories, it sounds suspiciously like a bad ground to the battery.

    Clean all the contacts, and maybe replace that woven ground strap (if that's the kind you have)... that will probably take care of it.
     
  3. unick

    unick 1/2 ton status

    Joined:
    Aug 16, 2003
    Posts:
    4,286
    Likes Received:
    0
    Location:
    San Diego Comufornia
    Yea like greg said its more than likely the grounds. I thought mine were going bad so I replaced them and the new ones r doing the exact smae thing.

    Nick
     
  4. JK5

    JK5 1/2 ton status GMOTM Winner

    Joined:
    Jan 31, 2002
    Posts:
    3,453
    Likes Received:
    1
    Location:
    Norton, Oh
    Like Greg said...check grounds..

    Check charging voltages...
    it should be 13.5 to 14.5 volts..

    On my 77'...
    I had problems with my accessories too!!!! /forums/images/graemlins/eek.gif
    The power windows and wipers were very slow..

    It took me a while to find the problem... I pulled the doors...
    and found some broken wires in the harness going to the window motors...

    Electrical problems can be time consuming... /forums/images/graemlins/eek.gif
     
  5. bnc04

    bnc04 Guest

    Thanks for the input, I'll be checking the grounds this weekend! /forums/images/graemlins/thumb.gif
    Brett
     

Share This Page