Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

SM465 Swap - a new question?

Discussion in 'The Garage' started by djohnsn, Mar 31, 2005.

  1. djohnsn

    djohnsn 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    327
    Likes Received:
    2
    Location:
    Plano, Texas
    I am working on my SM465 swap and discovered a new problem that I have not seen discussed before. The pedal setup came out of an 89 1-ton (old body style) with hydra boost. The problem is with the brake pedal. The point where the push rod attaches to the brake pedal (rod from brake pedal to booster) is in a slightly different place and is a slightly different size than the automatic pedal. I can deal with the different size easily enough, but I am worried that the location will be a problem since it changes the angle of the push rod. Anyone else have this problem? The mounting location seems to be 1/2" to 3/4" different between the two.
     
  2. darkshadow

    darkshadow 1 ton status

    Joined:
    Dec 6, 2003
    Posts:
    12,250
    Likes Received:
    0
    Location:
    C-eh-N-eh-D-eh
    interesting problem. i though the boster location was the same regardless of brake type. What truck are you putting this in?

    and couldent you grab the hydroboost off the doner and put it in to? better braking and you could make it so it solves your problem!??
     
  3. djohnsn

    djohnsn 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    327
    Likes Received:
    2
    Location:
    Plano, Texas
    It is going into a 78 K5. I thought that the booster location was the same also. Grabbing the hydra boost might solve my problem, but the truck that it was pulled from is no longer available.
     
  4. darkshadow

    darkshadow 1 ton status

    Joined:
    Dec 6, 2003
    Posts:
    12,250
    Likes Received:
    0
    Location:
    C-eh-N-eh-D-eh
    you could try leaving the stock pedel there, with a little work you can just add the cluch pedel to the stock brake brackit.

    like this
    [​IMG]
    and this

    [​IMG]

    you have read this right?: auto to manual swap
     
  5. captaininsano

    captaininsano 1/2 ton status

    Joined:
    May 4, 2004
    Posts:
    233
    Likes Received:
    0
    Location:
    Bay Area, CA
    Wow I am in the middle of my swap too, have to check and see if I have the same problem...will let you know.
     
  6. djohnsn

    djohnsn 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    327
    Likes Received:
    2
    Location:
    Plano, Texas
    Just FYI - I found another brake/clutch pedal setup in a local yard from a 85 truck (non-hydro boost). The 85 pedal bolted right up with no problems. It is a different pedal than the hydro boost setup (at least different between the two trucks that I pulled pedals from).
     

Share This Page