Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

smoke????? oh crap

Discussion in 'The Garage' started by uao85, Sep 18, 2004.

  1. uao85

    uao85 1/2 ton status

    Joined:
    Jan 2, 2004
    Posts:
    1,867
    Likes Received:
    0
    Location:
    Edge of insanity
    Well, I just finished my 6.0/4l80e swap into my blazer and it has brand new dual exhaust and I took it for the maiden voyage today just earlier and I noticed when I pulled into the driveway I thought I smelled something burning and saw a little smoke in the rear view mirror, but when I checked things out nothing was burnt at all everything looked fine. And I read a post a while back about a guy I think rifguitar who had new exhaust put on and had smoke and a funny smell coming from the exhaust for a short time. Could this be it, I think it is because its a brand new chevy crate motor, and brand new exhaust. Any ideas??? /forums/images/graemlins/dunno.gif

    Remington
     
  2. k20

    k20 3/4 ton status

    Joined:
    Sep 9, 2001
    Posts:
    5,068
    Likes Received:
    0
    Location:
    Mineral Springs, NC
    could be maybe rings arent set, and any residual oil in the exhaust just burning out, give it a day or two, if it doesnt clear up, then it might be more of a concern.
     
  3. k5mike

    k5mike Registered Member

    Joined:
    Jul 31, 2004
    Posts:
    29
    Likes Received:
    0
    Location:
    Houston,Tx.
    Same thing happened when I put a cat back on my 2000 cherokee....it's oil residue on the exaust to keep it from rusting......how does it run......I saw a write up on the 6.0L in a k5......hope all goes well......I'd like to get a look at it.....I work in west Houston...where are you at? /forums/images/graemlins/thumb.gif
     
  4. uao85

    uao85 1/2 ton status

    Joined:
    Jan 2, 2004
    Posts:
    1,867
    Likes Received:
    0
    Location:
    Edge of insanity
    Yeah I hope you are right. It runs ok right now, when I took it for a spin, I think the tranny fluid might have been low because it shifted a little sluggish so I will be topping it off in the morning. But after things clear up and the engine is broken in, then I will be adding a z06 cam and doing a valve job to the heads and maybe a few other odds and ends. I live in College Station right now since I just started college there @ A&M but I have been coming back to Friendswood(parents home) almost every weekend now for the last few months to get the blazer in a reliable running condition. I have been meaning to get some pics, so I guess I can try to snap some tomorrow before I head back to CSB. I will pb be back though the next few weekends so if you would like just let me know if you want to drop by. Thanks for all the ideas

    Remington
     
  5. rjfguitar

    rjfguitar 3/4 ton status GMOTM Winner

    Joined:
    Aug 28, 2002
    Posts:
    9,097
    Likes Received:
    144
    Location:
    california
    [ QUOTE ]
    And I read a post a while back about a guy I think rifguitar who had new exhaust put on and had smoke and a funny smell coming from the exhaust for a short time.

    [/ QUOTE ]Wasn't me. /forums/images/graemlins/smile.gif What color is the smoke?
     
  6. uao85

    uao85 1/2 ton status

    Joined:
    Jan 2, 2004
    Posts:
    1,867
    Likes Received:
    0
    Location:
    Edge of insanity
    oh well sry bout that, it was a medium grey smoke

    Remington
     
  7. diesel4me

    diesel4me 1 ton status Premium Member

    Joined:
    Jul 24, 2003
    Posts:
    17,560
    Likes Received:
    940
    Location:
    Massachussetts
    I used to sell arvin exhaust,and I assume walker and other brands do the same,they coat the pipes with a cosmoline type preservative so they wont rust hanging on the rack in the store waiting for you to buy it--it will stink for a little while,and perhaps a little smoke (the stickers with the part ## on them are plastic and will smell and smoke a little immediately after the first start when installed--if its smoking after 15 minites or so,its most likely somthing else. /forums/images/graemlins/crazy.gif
     

Share This Page