Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

so there i am, just driving along, when......

Discussion in '1982-Present GM Diesel' started by joez, Nov 7, 2003.

  1. joez

    joez 1/2 ton status

    Joined:
    Oct 21, 2003
    Posts:
    2,512
    Likes Received:
    0
    Location:
    New Lenox, Illinois
    she dies. i shouldnt say i was driving when it happened, it happened when i was going to make a left turn. trafic had slowed down, and as i merged into the turn lane, i giver her some right foot. not hard, but i wanted to make the light. i let off the pedal, and she just shuts down. i coast through the turn, pull off the road, put it in park, and just bump the key, fires right back up. it doesnt do it again for a few days, so i ignored it, thinking it was a fluke. well, today, it did the exact same thing. normal acceleration, i let off the gas, and its dead. i stop, bump the key, fires right up, and doesnt do it again.

    both times this has happened, it was still at or under about 100*, today the needle hadnt moved yet. when it is warm i can get on the skinny, and just let it off and it wont die.

    it is an 85 K5, 6.2, 700R4, with too many mile on it. i know the injection pump is starting to fail, its hard to start when warm, could this be the problem? maybee its just that its old and cold? i am investing in a new pump as soon as i find a good price on one, but has this happened to anyone else? was it the pump, or something else?
     
  2. BlueBlazer

    BlueBlazer 1/2 ton status

    Joined:
    Feb 15, 2001
    Posts:
    1,940
    Likes Received:
    0
    Sounds electrical as in either the injector pump fuel solenoid circuit or the circuit that feeds the ignition and other interior components. Does anything else turn off besides the engine, radio, etc? Check your connections at these places and go from there.
     
  3. joez

    joez 1/2 ton status

    Joined:
    Oct 21, 2003
    Posts:
    2,512
    Likes Received:
    0
    Location:
    New Lenox, Illinois
    thats what i thought too, but all connections are tight. everything else stays on, just the motor shuts off. doesnt sputer, nothing, just dead. ill fiddle with it tommarow and see if i can figure anything out.
     
  4. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,170
    Likes Received:
    1,379
    Location:
    E-town baby!
    If you do need a new pump check this place out:

    http://www.accuratediesel.com/

    I got my pump and my injectors rebuilt by them and am very pleased with the result! Great prices too, as well as excellent customer service. I sent my junk a little too close to when I had to be leaving for Blazer Bash...called them up and he pushed my stuff through on the double quick. Even sent along a personal note with my shipment wishing me a good trip to Utah. /forums/images/graemlins/thumb.gif

    Good customer service is hard to find, IMHO it should be rewarded.

    Rene
     
  5. dhdescender

    dhdescender 1/2 ton status

    Joined:
    Aug 10, 2002
    Posts:
    628
    Likes Received:
    0
    Location:
    Qualicum Beach, British Columbia, Canada - Eh.
    My truck was doing the same thing in random spots, it turned out that I had melted some starter wires to the exhaust and at random points it would short the whole system out and shut it down. pull over and it would start up again. Another Idea

    Jordan
     
  6. imiceman44

    imiceman44 1 ton status

    Joined:
    Aug 5, 2002
    Posts:
    15,160
    Likes Received:
    1
    Location:
    Sacramento, CA
    It happened to me too but mine was the Tranny.
    The automatic didn't like that letting go of the skinny.
    Rebuilt the tranny and all was fine.
    In your case i wouldn't know what it is.
     
  7. joez

    joez 1/2 ton status

    Joined:
    Oct 21, 2003
    Posts:
    2,512
    Likes Received:
    0
    Location:
    New Lenox, Illinois
    its the pump, its not doing the random death anymore, but the pump seems to be getting worse. i am ordering a rebuilt one, that should solve the warm start problems and this.
     
  8. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,170
    Likes Received:
    1,379
    Location:
    E-town baby!
    If you're gonna order a rebuilt pump check these guys out.

    http://www.accuratediesel.com/

    They rebuilt my pump and injectors, and I'm very happy with the way it runs now. /forums/images/graemlins/thumb.gif Pretty inexpensive compared to anywhere else I looked too.

    Rene
     
  9. joez

    joez 1/2 ton status

    Joined:
    Oct 21, 2003
    Posts:
    2,512
    Likes Received:
    0
    Location:
    New Lenox, Illinois
    thats where im headed, they seem very knowledgable and will answer questions honestly, without trying to cram a new pump at you.
     
  10. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,170
    Likes Received:
    1,379
    Location:
    E-town baby!
    Yeah, I found Tim to be very knowledgable and patient with me when I had mine done. Pretty rare to get a quality product, great price and good customer service at the same place! /forums/images/graemlins/thumb.gif

    Rene
     

Share This Page