Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Speedo don't work

Discussion in 'The Garage' started by fordeater, Jun 13, 2005.

  1. fordeater

    fordeater 1/2 ton status Premium Member

    Joined:
    Mar 21, 2004
    Posts:
    1,402
    Likes Received:
    0
    Location:
    Missoula, Montana
    Ok, so i swapped in a 465/205 into my blazer a few weeks ago, and now the speedo doesn't work. It worked before so i know its not the speedo/cable, i'm thinking it is the gear in the transfer case. So, the question is how do i replace it, and where can i get a new gear? Just in case anybody needs to know, its an 84 k5
     
  2. jekbrown

    jekbrown I am CK5 Premium Member GMOTM Winner Author

    Joined:
    May 19, 2001
    Posts:
    45,031
    Likes Received:
    366
    Location:
    Vancouver, WA, USA
    good question, i swapped in a 205 and haven't had a working speedo since. lol! to be honest, I don't really miss it...

    j
     
  3. fordeater

    fordeater 1/2 ton status Premium Member

    Joined:
    Mar 21, 2004
    Posts:
    1,402
    Likes Received:
    0
    Location:
    Missoula, Montana
    i'm fine without a speedo, but, this blazer is going to my lil 16 year old brother. I want him to see how fast he is going when his dumb ass is speeding all over the place
     
  4. RootBreaker

    RootBreaker 3/4 ton status Premium Member

    Joined:
    Nov 29, 2001
    Posts:
    5,117
    Likes Received:
    173
    Location:
    Williamstown, NJ USA
    my np205 has an adapter that is screwed into it..then my speedo cable goes into that.. maybe you are missing that?

    p.s. my speedo is way of now.. even though I finally put a cable in it.. not worth using..... cant find how to re-calibrate the manual trannies :crazy:
     
  5. pvfjr

    pvfjr 1/2 ton status

    Joined:
    Feb 10, 2004
    Posts:
    2,425
    Likes Received:
    0
    Location:
    Oakridge, OR
    I've seen that little drive pin that couples the speedo gear to the speedometer adapter strip a lot. It has a square shaft that slips into the t-case speedo gear, and it likes to get rounded off. Or maybe your speedo adapter is hosed, or the gear's missing from the t-case. Don't know what you swapped with it or what you kept, but if you haven't had the speedo adapter off of it yet, I'd give everything a good look.
     
  6. mudslinger99

    mudslinger99 1/2 ton status

    Joined:
    Oct 8, 2004
    Posts:
    512
    Likes Received:
    0
    Location:
    East Coast
    If you look on the passenger side of the transfercase you will see where the speedometer cable is attached.. Undo the cable from the side and there should be a metal clip with a 7/16 nut take it out.. You might have to screw the cable back in now to be able to pull the metal peice it attaches to out..Once you get that out you should see the little plastic gear.

    You can get the little plastic gear at your local dealer for about $7.00... You need to carry it with you so they can count the teeth.. Good luck
     

Share This Page