Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

speedo noise

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by i_4x4, Mar 8, 2001.

  1. i_4x4

    i_4x4 1/2 ton status

    Joined:
    Feb 20, 2000
    Posts:
    359
    Likes Received:
    0
    Location:
    Brighton, Colorado. USA
    My speedo started to make noise on the way home tonight. The speedo head was replaced 40,000 miles ago. I was thinking the cable needed to be lubed. Should I lube it w/ a dry graphite? Or something else? Any suggestions would be appreciated.

    Thanks in advance. Ed

    LET'S ROCK
    Don't follow me you will get STUCK!!
     
  2. MudRebel350

    MudRebel350 1/2 ton status

    Joined:
    May 20, 2000
    Posts:
    324
    Likes Received:
    0
    Location:
    N.J.
    I think the best grease to use is white grease. That should cure the problem.

    JD
     
  3. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    Graphite acts as an abrasive, and as such should not be used in moving parts. (speedo's, locks, etc) White lithium grease should be ok though.

    Dorian
    My K5 and Chev/Olds tech/links page: <A target="_blank" HREF=http://www.dorianyeager.com/index2.html>http://www.dorianyeager.com/index2.html</A>
     

Share This Page