Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Speedo Problems

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by RLBstein, Mar 9, 2001.

  1. RLBstein

    RLBstein 1/2 ton status

    Jul 2, 2000
    Likes Received:
    Pensacola, FL
    I hooked up my speedometer cable after the rebuild and made sure there weren't any bad bends and it was seated properly but at first it only read about 33 MPH when I was doing about 70 MPH. I wiggled it a little bit (the cable that is) and now it just spins around in complete circles. The faster I go, the faster it goes. While I like the psycadelic spiral effect i'm getting i'm worried about the speeding ticket effect I might get. Anyone have a remedy.

    85 Blazer on an 82 chassis, 6.2L Diesel, ORD flip, 35's with no cutting on a 4" lift.
  2. dyeager535

    dyeager535 1 ton status Premium Member

    Dec 13, 2000
    Likes Received:
    Roy WA
    I'd have to say the speedo unit is bad. The cable being bent will cause a "jumpy" or noisy condition. Not spinning all the way around that I know of. Never heard of that happening. They are easy to get out of busted clusters at the wrecking yard, and are not hard to change really, just a few screws and such. Might be worth it just to swap to make sure it is your problem, but I'm betting it is.... Much cheaper than getting a speeding ticket :)

    My K5 and Chev/Olds tech/links page: <A target="_blank" HREF=http://www.dorianyeager.com/index2.html>http://www.dorianyeager.com/index2.html</A>

Share This Page