Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Speedometer problem, on a 90' K5

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Taylor, Feb 8, 2003.

  1. Taylor

    Taylor 1/2 ton status

    Joined:
    Jul 17, 2002
    Posts:
    326
    Likes Received:
    0
    Location:
    Elizabeth, CO
    Speedometer problem, on a 90\' K5

    My speedometer and odomoter stoped working /forums/images/graemlins/confused.gif, since its an electric spedo I'm not sure how to go about troubleshooting it. I guessing that this pic1 is the spedo connection on the np241's rear output shaft, the cable runs up over the transfer case and junctions here pic2 and goes up over the trany and up toward the firewall. Is this the right cable? Any ideas on how I should start working on this?
     
  2. woody9

    woody9 1/2 ton status

    Joined:
    May 27, 2001
    Posts:
    602
    Likes Received:
    0
    Location:
    Howell, MI
    Speedometer problem, on a 90\' K5 (long)

    my 91 service manuals says..
    1 - Inoperative Digital Ratio Adapter (check voltage between brown wire in harness & good ground. Should = batt volt. check for open/short in brown wire)
    2 - poor ground path from Digital Ratio Adapter (check voltage between pink/black wire in harness & the black/white wire. should = batt volt. check for open/short in black/white wire)
    3 - no signal from veh speed sensor (with vehicle raised & supported, start and place in drive. check for AC voltage that changes with eng RPM on purple/white & light green/black @ dig ratio adapter. if no AC voltage, check for opens in both wires. No shorts/opens, replace veh speed sensor)
    4 - Inop digital ratio adapter (speedo output) (same as 3, but light green/black & white wire @ DRAC connector. No volt changes - replace dig ratio adapter)
    5 - Inop digital ratio adapter (cruise output) (raise & support as above, check for AC voltage to change with RPM between yellow & black/whte wire @ the dig ratio adapter connector (attached). If ac voltages changes with RPM, repace the DRA)

    Hope this helps..
     
  3. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    Re: Speedometer problem, on a 90\' K5

    If you can get your hands on a scan tool, believe it will tell you if the VSS is working or not. That would narrow your search down quite a bit.

    Anyone with '90/91 and scan tool verify that vehicle speed does show up while driving with the scanner running?
     
  4. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    Re: Speedometer problem, on a 90\' K5

    check the fuse
     
  5. Taylor

    Taylor 1/2 ton status

    Joined:
    Jul 17, 2002
    Posts:
    326
    Likes Received:
    0
    Location:
    Elizabeth, CO
    Re: Speedometer problem, on a 90\' K5

    Wow I dont beleive it, it was the fuse for the heater. Dosent make any sence how it ties into the spedo, but oh well its freakin working now! Thanks Guys! /forums/images/graemlins/smile.gif
     
  6. BlazinRojo

    BlazinRojo 1/2 ton status

    Joined:
    Mar 29, 2001
    Posts:
    111
    Likes Received:
    0
    Location:
    San Luis Obisbo, CA
    Re: Speedometer problem, on a 90\' K5

    you think that wiring is weird? in my 83 the torque converter lockup clutch power draws from the stereo fuse! Helped in troubleshooting though, when ever the clutch shorted out, the tunes stopped!
     

Share This Page