Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

speedometer WAY off

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by BillR, Apr 2, 2000.

  1. BillR

    BillR 1/2 ton status

    Joined:
    Mar 15, 2000
    Posts:
    164
    Likes Received:
    0
    Location:
    Flagstaff, AZ
    At 25-30 mph, my speedometer reads a little high. At 70-75, it's reading over 100 mph! It also floats around a little. I checked the cable into the case, and it's tight. Ideas?

    Blazin' in Flagstaff
     
  2. Blaize

    Blaize Registered Member

    Joined:
    Feb 24, 2000
    Posts:
    45
    Likes Received:
    0
    Location:
    Torrance, California, USA
    BillR, what size tires are you running ? If you have changed the tire size, you've also changed the speedometer AND the odometer readings. I have the same problem (36" tires on mine), and will probably have a speedometer shop install a "reduction gear" behind the speedometer assembly to correct this. Also, the speedometer cable probably needs to be lubed, that's one reason why it fluctuates.

    Also, the gearing in your differentials will affect the readings. Until I get my rear differential gears changed (from 3:08-ouch!- to 4:56 or 4:73) I've done the following. I took the wifes super-accurate 4Runner around our block 3 times and documented the milage, which was 4.9 miles. i then took the K5 around the same block, and the odometer showed only 4.1 miles. The correction factor for mine is 20%, so when my odometer shows 100 miles, for example, I've really gone 120 miles. This is important information for calculating gas milage, and for estimating the "next service" (i.e.: oil change, etc).

    AAA (Auto Club) has a calibration print-out that you can get, which lists your speed against "real" speed. I posted this print-out in my previous Blazer, so I wouldn't get speeding tickets, and it worked!

    Anyways, I hope this all made sense, and I hope this helps you out !

    Blaize
     
  3. Eagle86K5

    Eagle86K5 1/2 ton status

    Joined:
    Mar 5, 2000
    Posts:
    974
    Likes Received:
    0
    Location:
    Whitehouse, Ohio
    I went to the chevy dealer...told the guy the problem, he went to the book, came back with a gear and I installed it no problem. On the cable...remove the dash bezel and then the cluster behind it. press down on the clip that holds the speedo cable in and pull the cable loose, I used wd-40 and just sprayed a bunch in the top of the cable, loosened it right up. Put it back together and no more problem.

    <font color=green>Eagle86K5[​IMG]

    <font color=red>Only guy I know that can get out of line in a one car funeral
     

Share This Page