Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Starts, won't run '98 C2500 & '99 Yukon

Discussion in '1992-Present Chevy & GMC models' started by 73k10sub, Nov 25, 2003.

  1. 73k10sub

    73k10sub 1/2 ton status

    Joined:
    Jul 23, 2001
    Posts:
    223
    Likes Received:
    0
    Location:
    Tulsa, OK
    Starts, won\'t run \'98 C2500 & \'99 Yukon

    It started happening on the PU about 2 years ago. A mechanic, on a trip to Texas, managed to get one code out of it (the service engine light never comes on). The bottom line seems to be the vehicle does not recogonize the key - "thinks" it is being hot wired and the security system shuts off the fuel (the reason it starts and dies). My mechanic here could never get a code and without it says he could only R&R parts hoping we finally hit it! He suggested having the computer de-programmed and that is what I finally had done (he called it removing the VATS) after being stranded several times. Usually, I would have to let it set an hour, to overnight, before it would start and run. I've not had it happen since!!!

    NOW, the Yukon pulls the same thing on the wife last week.

    I've talked to a friend and one local dealership and my mechanic has called dealer mechanics and service people he knows and no one knows, or will admit, to any service bulletins on this problem.

    Anybody got a clue. This is the pits when you can't trust them to start and run. Both are 2WD.

    Ronnie /forums/images/graemlins/1zhelp.gif /forums/images/graemlins/confused.gif /forums/images/graemlins/angryfire.gif /forums/images/graemlins/mad.gif
     
  2. Confedneck

    Confedneck 3/4 ton status

    Joined:
    Nov 1, 2002
    Posts:
    5,236
    Likes Received:
    0
    Location:
    Lehigh Acres, Florida
    Re: Starts, won\'t run \'98 C2500 & \'99 Yukon

    starts and wont run? you mean cranks and doesnt start? if the "theft" or "security" light stays on, then you have a passive theft deterrent problem, ie the electronic chip keys, you need to have it checked out by a GM dealer to have the problem properly diagnosed...we get these kind of things at the ford dealer i work with, and your best bet is the dealer..
     
  3. 73k10sub

    73k10sub 1/2 ton status

    Joined:
    Jul 23, 2001
    Posts:
    223
    Likes Received:
    0
    Location:
    Tulsa, OK
    Re: Starts, won\'t run \'98 C2500 & \'99 Yukon

    I should have said, "it cranks, starts, then dies". The mechanics say it is running out of fuel because of the fuel shut off.
    Both these vehicles have regular keys, i.e. no chips. No lights stay on.
     
  4. Confedneck

    Confedneck 3/4 ton status

    Joined:
    Nov 1, 2002
    Posts:
    5,236
    Likes Received:
    0
    Location:
    Lehigh Acres, Florida
    Re: Starts, won\'t run \'98 C2500 & \'99 Yukon

    well if they have no chips, willing to bet its in the ignition switch or anti-theft module itself..possibly a corroded/loose connection?
     
  5. got_mud

    got_mud 1/2 ton status

    Joined:
    May 9, 2003
    Posts:
    316
    Likes Received:
    0
    Location:
    Wichita, KS
    Re: Starts, won\'t run \'98 C2500 & \'99 Yukon

    its likely the vats. my 96 c3500 and my wifes 99 yukon both have done it to me. my 99 c3500 never has- i had the vats bypassed when i installed my remote start/keyless entry. upgraded the keyless on the yukon to keyless/remote start alarm and it hasn't done it since. check with the dealer to compare the cost of having the vats inspected and repaired versus having a remote starter installed by a competent shop. in the meantime if it does it again pull the key out, step and hold the brake pedal and restart it with the key turned 180 degrees. hope that makes sense. worked twice for me on the 96 but didn't work on the 99.
     

Share This Page