Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

steering prob.

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by dunn, May 2, 2003.

  1. dunn

    dunn Registered Member

    Joined:
    Apr 25, 2003
    Posts:
    7
    Likes Received:
    0
    Location:
    ca.
    ok. i am stumped! i have a 76 k5 4x4 and i have always had this prob a little but now its getting worse and a little scarry! here we go, when i am driving strait and w/o touching the brakes my front tires start to vear left a little so i go to correct it and nothing for about 1 sec and then the truck darts in the diriction i have the steering wheel! has anyone heard of this? ive replaced the entire front rods and rod ends. and still nothing. and its always to the left. please help! thanxs /forums/images/graemlins/confused.gif /forums/images/graemlins/k5.gif
     
  2. Shaggy

    Shaggy 3/4 ton status

    Joined:
    Dec 15, 2000
    Posts:
    6,737
    Likes Received:
    0
    Location:
    Los Banos, CA
    <font color="green"> With the truck stationary, can you move the steering a lot? There could be alot of play in the steering box, but it can be adjusted with the screw on top of it. </font>
     
  3. dunn

    dunn Registered Member

    Joined:
    Apr 25, 2003
    Posts:
    7
    Likes Received:
    0
    Location:
    ca.
    there is a little, ive replaced the leather washer too. ok if i adjust the box which way is it to tighten it?
     
  4. Shaggy

    Shaggy 3/4 ton status

    Joined:
    Dec 15, 2000
    Posts:
    6,737
    Likes Received:
    0
    Location:
    Los Banos, CA
    <font color="green"> If there's only a little play then you might want to look elsewhere for the cause of the problem first. Have you checked the alignment? Made sure that the steering arm is tight? Tie rod AND drag link ends were replaced and/or checked? Steering box is solidly attached to the frame and the frame is not cracked (VERY common problem on these trucks)?</font>
     
  5. dunn

    dunn Registered Member

    Joined:
    Apr 25, 2003
    Posts:
    7
    Likes Received:
    0
    Location:
    ca.
    all of that is new, and the truck does not pull except when it does this, and it only does it every once and awhile. and i have the box brase.
     
  6. Shaggy

    Shaggy 3/4 ton status

    Joined:
    Dec 15, 2000
    Posts:
    6,737
    Likes Received:
    0
    Location:
    Los Banos, CA
    <font color="green"> did you make sure that the u-bolts are all tight? Spring pins haven't sheared? Spring bushings are in good shape? As for the steering box adjustment, I've never actually adjusted one, so I will leave that to someone else to describe how to do. Or you could do a search on it, you will surely find something about it since it is discussed fairly regularly. /forums/images/graemlins/thumb.gif </font>
     
  7. Can Can

    Can Can Pusher Man Staff Member Super Moderator

    Joined:
    Feb 17, 2000
    Posts:
    15,552
    Likes Received:
    136
    Location:
    Cochrane, Alberta, Canada
    Have you checked out your draglink ends?? I was having similar steering issues, and after replacing upper/lower ball joints on both sides and my tie rod ends, I realized that my draglink ends were pretty worn. After swapping in new Moog ends my steering was WAY tighter.

    Hope this helps, brother.......
     
  8. opfor2

    opfor2 1/2 ton status

    Joined:
    Oct 28, 2002
    Posts:
    375
    Likes Received:
    0
    Location:
    Ventura County, CA
    Check the hub nuts !!!(spindel nuts) If they are lose then your front end will be off and the truck will pull to the left or right. that's the problem that I had with my Blazer.

    Dan..
     
  9. dunn

    dunn Registered Member

    Joined:
    Apr 25, 2003
    Posts:
    7
    Likes Received:
    0
    Location:
    ca.
    over the weekend i replaced the gear box and the p.s pump and the damn prob is still there!!! its weird that it only does it every once and awhile. like something gets stuck for a second. thanks for all the advice! im going to tighten the hub nut this weekend and see what that does. but i wouldnt think that would cause it to stick to the left only. i have dual steering stab on it thats pretty old, would that have anything to do with it? /forums/images/graemlins/confused.gif /forums/images/graemlins/confused.gif /forums/images/graemlins/confused.gif
     

Share This Page