Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

steering problems continue!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 88k5blaza, Nov 19, 2002.

  1. 88k5blaza

    88k5blaza Registered Member

    Joined:
    Oct 17, 2002
    Posts:
    70
    Likes Received:
    0
    Location:
    new hampshire
    have had this steering problem for a while with my stock 88 k5 it started pulling all over the place with no warning it would jolt and if you turned it would just turn very drasticaly, it did something similar b4 and i replaced the steering stabalizer, so i did that again because it looked like the seal was leeking, didnt work so i tried taking the box apart cleaned it out, blew out the ines and flushed the system bolted it together adjusted it, still did it, now i just put in a remanufactored steering box and it got better but still jolts and pulls when its cold, im lost and out of ideas so any help would be appriciated!
     
  2. Chaz88K5

    Chaz88K5 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    2,979
    Likes Received:
    0
    Location:
    Stockton/Lodi CA
    well i had a wandering problem and everytime i would turn sharp it would pop...well a year later i found out what was wrong...frame broke...while on the rubicon ..so what i am gettin at...check the frame around the bolt holes where the box bolts to
     
  3. imiceman44

    imiceman44 1 ton status

    Joined:
    Aug 5, 2002
    Posts:
    15,160
    Likes Received:
    1
    Location:
    Sacramento, CA
    Well since you replaced the box I am assuming that you would have seen a crack in the frame.
    But if you didn't look, Chazz is right that could be your problem.
    Another thing that will do this is an axle U joint that is dry and binding. Or any of the ball joints, they do that too if dry.
    And last, one time I had some play in the steering and I assumed it was the box, but later when it got worse, I found that the U bolts on the spring pack were loose, and I guess the pin sheared off because the axle was sliding on the spring back and forth 4 inches!!!
    Start by checking the frame, then grease the ball joints, and check the axle U joints.
     
  4. 88k5blaza

    88k5blaza Registered Member

    Joined:
    Oct 17, 2002
    Posts:
    70
    Likes Received:
    0
    Location:
    new hampshire
    yea i herd that about the U joints and theyre all greased and the u bolts are tight and the axles dont move but im gonna try regreasin hte ball joints i did it a while ago but i dont drive it alot so it could be stiff or dry thanks for the help guys!
     

Share This Page