Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Strange Leak

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by ggallin13, Aug 15, 2000.

  1. ggallin13

    ggallin13 1/2 ton status

    Joined:
    Mar 31, 2000
    Posts:
    199
    Likes Received:
    0
    Location:
    Northern Nevada
    I have an oil leak that just happens to drip on my exhaust pipe and smoke and smell terribly. It is driving me nuts! I have looked up to where the oil is coming from and it looks like the pressure sensor. There are two wires coming off this thing, and it plugs in just above the filter. I am going to swap it out myself, but I can't tell where the wires go! Help! Oh--it only leaks while running, when it is shut off there is no leakage.

    Here is the weird thing: After putting a new exhaust system in (it sounds and runs sweeeet [​IMG] and servicing the tranny it leaked worse and now it doesn't at all. I don't get it.

    [​IMG]
     
  2. Scoobydoo

    Scoobydoo 1/2 ton status

    Joined:
    Jun 9, 2000
    Posts:
    244
    Likes Received:
    0
    Location:
    Phoenix / Peoria ARIZONA. (75thAve/DeerValley)
    I had that oil pressure sender leak a short time ago.
    CHANGE IT NOW !!! mine had 3 wires coming out the back, they are part of a plug so you just unplug them all together, from the sender. The reason I tell you to change it now is because on mine, there is a small plug or check valve or something right between those wires (you won't see it until you remove the sender) that plug or whatever will completely come off!!! and then oil will be "SHOOTING" out of there at around 40 to 60 PSI you will lose all of your oil in a matter of minutes!
    Luckily for me, mine blew out in my driveway, you may not be so fortunate.
    Consider yourself LUCKY because it has given you a fair warning!
    You may want to buy a lottery ticket ![​IMG]
     
  3. KrebsATM02

    KrebsATM02 1/2 ton status

    Joined:
    Mar 21, 2000
    Posts:
    553
    Likes Received:
    0
    Location:
    College Station, Texas
    Sure it's not the knock sensor? - Doug

    Doug Krebs
     
  4. Scoobydoo

    Scoobydoo 1/2 ton status

    Joined:
    Jun 9, 2000
    Posts:
    244
    Likes Received:
    0
    Location:
    Phoenix / Peoria ARIZONA. (75thAve/DeerValley)
    The one I had to replace was on my wifes "87 S15 Jimmy 4wd" it was right above the oil filter.
    I KNOW mine was the sender for the oil pressure gauge.
    So you are right I don't KNOW what his is, but it sounded like the same thing?
    either way I would suggest he replace it ASAP
     
  5. DMK

    DMK 1/2 ton status

    Joined:
    Feb 20, 2000
    Posts:
    757
    Likes Received:
    0
    Location:
    CINCINNATI, OH
    Knock sensor is more to the middle of the block.
     

Share This Page