Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Strange noises from the cooling system????

Discussion in 'The Garage' started by Tshane, Sep 6, 2003.

  1. Tshane

    Tshane 1/2 ton status

    Joined:
    Nov 26, 2002
    Posts:
    144
    Likes Received:
    0
    Location:
    Peoria, Illinois
    Last weekend I helped my cousin put a 400 into his bronco and we got everything going and running. Sounds great until you turn it off. When you turn it off it has a violent clickin noise that shakes the whole truck. You can tell that it is something in the coolin system. We made sure to purge all teh air out and still did it. It sounded like the thermastat so we replaced that with a new one and it continued to do it. Just wondering if anyone knew wtf is going on??? thanks........I dont know much about fords and wondering if it had to something with that engine or a common thing.
     
  2. Okiemuddog

    Okiemuddog 1/2 ton status

    Joined:
    Mar 3, 2003
    Posts:
    1,260
    Likes Received:
    0
    Location:
    Guthrie, Oklahoma
    If I was to take a guess, I would say it was the pressurized water form the pump pushing back from the block into the radiator, my Mother's burb does the same thing, I would say nothing to worry about. You might try draining some of the water out of the radiatior and making sure you have it filled to the "full when cold" mark on the radiaitor. Just my 2 cents


    Krennen
     

Share This Page