Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Stupid me! (winch problem)

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by ChadH82, Aug 11, 2001.

  1. ChadH82

    ChadH82 1/2 ton status

    Joined:
    May 9, 2001
    Posts:
    400
    Likes Received:
    0
    Location:
    Stillwater, Oklahoma
    I was using my Warn winch yesterday. Not paying attention to the dangling controlling cord, I started winching and pinched the cord between the cable and the fairlead. The cord started smoking and then the controller box joined in. I haven't taken the cover off the box yet to check out the damage, but has anyone done this before? If so what do I need to get to fix it. Thanx

    Chad
     
  2. michaelm

    michaelm 1/2 ton status

    Joined:
    Feb 2, 2001
    Posts:
    872
    Likes Received:
    0
    sounds like you shorted the wires in the cord. you need a new cord.
    switch may or may not be toast but safer to replace.
    open up control box and test solenoids and look for obvious damage.
    sounds like you sent power to all the solenoids at once creating a short.
    i would buy all new solenoids, test the old ones and if any seem to work toss them in the tool box/glove box as spares
     
  3. mudhog

    mudhog THEGAME Staff Member Super Moderator

    Joined:
    Nov 6, 2000
    Posts:
    17,899
    Likes Received:
    2
    Location:
    portland oregon

Share This Page