Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

stuttering feel on tight slow turns

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by zach78k5, Mar 17, 2001.

  1. zach78k5

    zach78k5 1/2 ton status

    Joined:
    May 14, 2000
    Posts:
    406
    Likes Received:
    0
    when i turn the wheel hard left or right and i am going slow, forward or back, the truck feels like it is stuttering sort of. i have 33/ 12.5 tires and positraction in the rear. would either of these give this feel. it just sort of worries me, but i hope it is nothing. if you have any ideas let me know.
     
  2. muddin4fun

    muddin4fun 3/4 ton status

    Joined:
    Feb 19, 2001
    Posts:
    5,644
    Likes Received:
    0
    Location:
    N Texas
    Is it like the wheel is stuttering while you are turning it (the wheel)? Cause mine does that and I can't figure out why.

    [​IMG]

    <A target="_blank" HREF=http://muddin4fun.coloradok5.com>http://muddin4fun.coloradok5.com</A>
     
  3. BurbinOR

    BurbinOR 3/4 ton status

    Joined:
    Feb 17, 2000
    Posts:
    5,829
    Likes Received:
    0
    Location:
    Oregon
    If your truck is still full time the "stutter" is basically normal.

    <font color=orange>'79 - 406 TPI -<font color=orange> K5#5 - <font color=blue>See it at---&gt;<A target="_blank" HREF=http://www.blazzinor.coloradok5.com>http://www.blazzinor.coloradok5.com</A>
     
  4. muddin4fun

    muddin4fun 3/4 ton status

    Joined:
    Feb 19, 2001
    Posts:
    5,644
    Likes Received:
    0
    Location:
    N Texas
    mkay....what if it's part time?

    [​IMG]

    <A target="_blank" HREF=http://muddin4fun.coloradok5.com>http://muddin4fun.coloradok5.com</A>
     
  5. Pure Insanity

    Pure Insanity 1/2 ton status

    Joined:
    Mar 17, 2001
    Posts:
    4,579
    Likes Received:
    0
    Location:
    Dade City, Florida
    if it feels like its stuttering WHILE your turning,your p/s pump may be weak.try it at idle,thenspeed up the motor and try,if the stutter goes away it may be the pump.the lugs on my hawgs used to catch on my springs at full turn.scared the life outta me 1st time it did it!i thought it was comin apart.


    pure insanity
     
  6. Pure Insanity

    Pure Insanity 1/2 ton status

    Joined:
    Mar 17, 2001
    Posts:
    4,579
    Likes Received:
    0
    Location:
    Dade City, Florida
    oh wait i forgot you have posi!!it could be the rear diff tryin to lock bcuz of the difference in wheel speed in a turn.you just dont feel it at higher speed lesser turns.

    pureinsanity
     
  7. DMK

    DMK 1/2 ton status

    Joined:
    Feb 20, 2000
    Posts:
    757
    Likes Received:
    0
    Location:
    CINCINNATI, OH
    Loose ps pump belt, loose brakets. Mine did this and the bottom bracket was missing.
     
  8. HarryH3

    HarryH3 1 ton status Author

    Joined:
    May 31, 2000
    Posts:
    10,384
    Likes Received:
    2
    Location:
    Georgetown, TX
    Make sure that you aren't holding the steering wheel against the internal pump stops. When it won't turn any further, back off an inch or two. Otherwise your pump is working really hard against full pressure.

    <font color=black>HarryH3 - '75 K5</font color=black>
    <A target="_blank" HREF=http://ThunderTruck.ColoradoK5.com>http://ThunderTruck.ColoradoK5.com</A>
     
  9. jcg

    jcg 1/2 ton status

    Joined:
    Mar 19, 2000
    Posts:
    660
    Likes Received:
    0
    Location:
    Rochester, NY
    Yeah, it's most likely the posi catching and trying to make the truck plow into the turn. My lockright does it if I try to turn sharp and I'm going too fast, the front end starts to shudder as it plows. Scares the hell outta people walking by, especially when the locker slips and then catches again... makes that nice loud bang that seems to use the brake drums to amplify it. The things we do for better performance off-road...

    Joe
    RIT Mini-Baja http://www.rit.edu/~bajawww
    Team Mudnuts http://www.mudnuts.org
     
  10. 88MudBeast

    88MudBeast Registered Member

    Joined:
    Nov 8, 2000
    Posts:
    67
    Likes Received:
    0
    Location:
    Dallas, TX
    mine only does it in 4WD.
    Big Jake

    Drive it like you stole it.
     
  11. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    I would be changing the fluid in teh rear diff. Could have been changed, and no posi diff lube added. That could be posi chatter. As well, if it is a gov-lok, it may be locked up all the time, mine was. Mine wasn't as bad at low speeds as it was high..sounds to me like posi chatter.


    Dorian
    My K5 and Chev/Olds tech/links page: <A target="_blank" HREF=http://www.dorianyeager.com/index2.html>http://www.dorianyeager.com/index2.html</A>
     

Share This Page