Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

summit cam and tbi questions

Discussion in 'The Garage' started by big_truxx, Aug 17, 2005.

  1. big_truxx

    big_truxx 1/2 ton status

    Joined:
    Oct 8, 2004
    Posts:
    2,272
    Likes Received:
    0
    Location:
    Canaan, Maine
    i wanna run a summit 1300 cam in my 454 when i rebuild. will that run ok w/o burning a chip or whatever? i know nothing about burning chips or tbi and cams etc. thanks for the help!! :waytogo:
     
  2. southernspeed

    southernspeed 1/2 ton status GMOTM Winner

    Joined:
    Dec 24, 2003
    Posts:
    4,395
    Likes Received:
    50
    Location:
    VA
    I'm not familiar with that cam. I used an Edelbrock Performer TBI cam and it runs fine with the stock chip, and that's with flat top pistons too.
    I'd seriously think about using a cam that is recommended for TBI motors rather than buying an 'unknown' and possibly having loads of running problems.
     
  3. big_truxx

    big_truxx 1/2 ton status

    Joined:
    Oct 8, 2004
    Posts:
    2,272
    Likes Received:
    0
    Location:
    Canaan, Maine
    but that means paying $150 more for a am that looks sooooooo similar in specs to the sum 1300... thats kinda :screwy:
     
  4. southernspeed

    southernspeed 1/2 ton status GMOTM Winner

    Joined:
    Dec 24, 2003
    Posts:
    4,395
    Likes Received:
    50
    Location:
    VA
    My book says $123 for a Performer plus cam kit?
     

Share This Page