Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

T-Case grinding

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by BowtieRed, Jan 23, 2003.

  1. BowtieRed

    BowtieRed 1/2 ton status Author

    Joined:
    Dec 31, 2002
    Posts:
    1,776
    Likes Received:
    0
    Location:
    Winston-Salem, NC
    My transfer case will not grind in 4Hi. But in every other 'gear' it will grind like crazy. Well, usually. After I shift back into 4Hi aftre i finish wheelin it'll grind for a while, and be ok, and then grind over bumps. I'll mess with it a little until it stops grinding. And this grinding is LOUD. People will look at me on the road and try to figure out what's wrong. I have pulled up to my friends' house and he says he heard me from over a quarter mile away. I canot figure out what it is, and it scares the hell outta me. I have an NP203 from a 78 K5 mated to a TH350.
     
  2. muddysub

    muddysub 1 ton suburban status Staff Member Moderator GMOTM Winner

    Joined:
    Jun 23, 2001
    Posts:
    10,451
    Likes Received:
    489
    Location:
    my garage, Henderson, NV
    dang i don't have a clue! /forums/images/graemlins/eek.gif
     
  3. imiceman44

    imiceman44 1 ton status

    Joined:
    Aug 5, 2002
    Posts:
    15,160
    Likes Received:
    1
    Location:
    Sacramento, CA
    Check the fluids.
     
  4. wheelin_willy

    wheelin_willy Registered Member

    Joined:
    Jan 23, 2003
    Posts:
    24
    Likes Received:
    0
    sounds pretty bad are you sure you using the RIGHT fluid. regular 30 weight engine oil is the right one.
    if all else fails pull the inspection cover and check out the carnage.
    afterthought......is the linkage o.k.?
     
  5. BowtieRed

    BowtieRed 1/2 ton status Author

    Joined:
    Dec 31, 2002
    Posts:
    1,776
    Likes Received:
    0
    Location:
    Winston-Salem, NC
    I'll do that as soon as all this f*&%#%$ snow melts. It's really bothering me and i have this terrible feeling it's going to fall out on day.
     
  6. ken

    ken 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,244
    Likes Received:
    0
    Location:
    Anaheim, CA
    HA! The same thing happened to my 203 just last night!! My wife has been driving the rig and tells me last night that it's been grinding off and on for a week!! /forums/images/graemlins/shocked.gif It only grinds in hi range and hi lock...it does not grind in low or low-lock!! I drove it 25 miles home on the freeway in lowrange at 45 MPH and 4,000 RPMs!!! NOT FUN!!! I know the case is smoked, and haven't checked the fluid yet...I bet there is none in there!!! Shouldda check that sooner!!! Oh well, time to install my TH400-203 for the doubler!!
     
  7. BowtieRed

    BowtieRed 1/2 ton status Author

    Joined:
    Dec 31, 2002
    Posts:
    1,776
    Likes Received:
    0
    Location:
    Winston-Salem, NC
    did it like rumble and you could feel the vibration strongly throughout the truck?
     

Share This Page