Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

tail light problem, dunno how to fix!!

Discussion in 'The Garage' started by chevy_mud_84, May 1, 2006.

  1. chevy_mud_84

    chevy_mud_84 Registered Member

    Joined:
    Feb 28, 2005
    Posts:
    89
    Likes Received:
    0
    Location:
    Brockville, ON, Canada
    I all of a sudden came across this tail light problem last night when none of my tail lights worked. it seems that when my head lights are on i have no brake lights, or running lights, or singnel lights or reverse lights. but when my headlights are off, i have brake lights and reverse lights, but when i put my signles on, whether the headlights are on or not they blink normal in the front but both rear tail lights blink as if my 4ways where on. This all happened last night, and its hard trying to get back and forth from school/work and not get pulled over and piss ppl off. I think its either got a short somewhere, or maybe my light switch is screwed??? Anyone know my problem???
    Thanks
    Josh
     
  2. blazinzuk

    blazinzuk Buzzbox voodoo Premium Member GMOTM Winner

    Joined:
    Dec 20, 2002
    Posts:
    17,412
    Likes Received:
    3,799
    Location:
    Afton / Star Valley Wyoming
    Pull the bulbs check for corrosion and clean and put new bulbs in, check the grounds and replace the flashers(little silver round things on your fuse box) I bet all or one of those things will fix it:D
     
  3. hack500

    hack500 1/2 ton status

    Joined:
    Sep 16, 2005
    Posts:
    523
    Likes Received:
    0
    Location:
    Templeton, Ma
    had a bad bulb/socket and my burban acted almost identical to that... . :doah:
     
  4. zeroz400

    zeroz400 1/2 ton status

    Joined:
    May 30, 2004
    Posts:
    410
    Likes Received:
    0
    Location:
    Libertyville, IL
    I would say a bad ground, they always cause funny things to happen.
     
  5. loafer

    loafer 1/2 ton status

    Joined:
    Aug 19, 2003
    Posts:
    634
    Likes Received:
    0
    Location:
    Lyman, Maine
    This same thing happend to me on an old truck; The ground wire attached to body on the driver's side had rusted enough the that the screw came out. I just drilled a new hole for the ground.
     
  6. R77K10

    R77K10 Banned

    Joined:
    Mar 15, 2006
    Posts:
    564
    Likes Received:
    0
    Location:
    Lincoln IL
    ground problem

    time to take out the taillight assemblies and clean or reattach the grounds

    i have the same problem on one side of my 77 one brake light doesnt work with the headlights on
    but i dont care i aint fixing it anytime soon


    the best fix is to take ap iece of wire and crimp a ring connector on one end and self tapping screw it to a clean spot of metal near the taillight asembly and use that for your ground

    good luck
     
  7. k20

    k20 3/4 ton status

    Joined:
    Sep 9, 2001
    Posts:
    5,068
    Likes Received:
    0
    Location:
    Mineral Springs, NC
    check the ground strap on the left rear socket, and if its good, check the ground from the frame to the bed.

    When I had a spray in line-x done, it screwed up the ground for my bed, and it did something similar, and I had to run another groundstrap from the bed to the frame.
     

Share This Page