Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

TBI 350 Smoke comin out the preheater hose on warm up???

Discussion in 'The Garage' started by 89K1500Chevy, Feb 27, 2003.

  1. 89K1500Chevy

    89K1500Chevy 1/2 ton status

    Joined:
    Nov 9, 2002
    Posts:
    645
    Likes Received:
    0
    Location:
    Georgia, Fayetteville
    What would cause smoke to come out the preheater hose and the Check engine light to come on? I scanned it and it said MAP sensor so i put a new one on there from Napa and i put some sealer on the vacume hoses to make sure they werent leakin but it is still happening.... Anyone have any suggestions?? Im lost on this. Truck idles kinda rough now too. Wants to idle high then go low and almost die has stalled a few times idling.. /forums/images/graemlins/1zhelp.gif /forums/images/graemlins/truck.gif /forums/images/graemlins/usaflag.gif www.zombieoffroading.8m.net
     
  2. TopOff

    TopOff 1/2 ton status

    Joined:
    Jan 16, 2002
    Posts:
    1,760
    Likes Received:
    0
    Location:
    Folsom, ca
    EGR?

    Smoke on the pre-heater hose? Check to make sure nothing is on the exhaust manifold. Could also be a leaky valve cover gasket leaking there near your heater hose.

    Good luck.
     
  3. 89K1500Chevy

    89K1500Chevy 1/2 ton status

    Joined:
    Nov 9, 2002
    Posts:
    645
    Likes Received:
    0
    Location:
    Georgia, Fayetteville
    I also put a new EGR on there and the preheater hose comes off passenger side exhaust manifold to the air cleaner housing. /forums/images/graemlins/truck.gif /forums/images/graemlins/usaflag.gif
     

Share This Page