Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

TBI 454... bad hesitation. Just doesn't "open up"

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by mountainexplorer, Apr 27, 2004.

  1. mountainexplorer

    mountainexplorer 1/2 ton status

    Joined:
    Nov 14, 2001
    Posts:
    4,903
    Likes Received:
    0
    Location:
    Spokane, Wa./Ione, Wa
    TBI 454... bad hesitation. Just doesn\'t \"open up\"

    What would cause a TBI motor to just bog down when stepping on the gas?

    It does it really bad when it's cold. Idles fine, but when you go to give it gas to accelerate, it just bogs down. If you really get on it, it sounds like you can hear the butterflies on the TBI unit open up, but it doesn't do anything. If you just barely step on the gas, and accelerate slowly, it seems fairly smooth. It seems to improve when the motor is totally warmed up, but it still doesn't open up like it should.
     
  2. Topdown

    Topdown 1/2 ton status

    Joined:
    Nov 26, 2002
    Posts:
    2,598
    Likes Received:
    0
    Location:
    Vancouver, Washington, U.S.A
    Re: TBI 454... bad hesitation. Just doesn\'t \"open up\"

    black smoke from the tailpipe? - running too rich, it will bog like a mofo

    No black smoke from the pipe? - May be running too lean, it will bog like a mofo here too...

    Thats all the thoughts I have... hope it helps.
     
  3. 84_Chevy_K10

    84_Chevy_K10 Banned

    Joined:
    May 30, 2001
    Posts:
    17,669
    Likes Received:
    0
    Location:
    IL, USA
    Re: TBI 454... bad hesitation. Just doesn\'t \"open up\"

    Sounds like a vacuum leak is a very likely culprit.
     
  4. Thunder

    Thunder 3/4 ton status

    Joined:
    Jul 20, 2000
    Posts:
    8,946
    Likes Received:
    1
    Location:
    Northeast Nevada
    Re: TBI 454... bad hesitation. Just doesn\'t \"open up\"

    When was the last time you changed the fuel filter?
    Might also be a bad TPS. Is it throwing any codes?
     
  5. mountainexplorer

    mountainexplorer 1/2 ton status

    Joined:
    Nov 14, 2001
    Posts:
    4,903
    Likes Received:
    0
    Location:
    Spokane, Wa./Ione, Wa
    Re: TBI 454... bad hesitation. Just doesn\'t \"open up\"

    It doesn't blow any smoke at all.

    I'll have to check for vacuum lines being disconnected or broken, but I can't hear anything like air hissing.

    First thing I'll do is check the fuel filter.

    I'm sure it just needs a tune up too. Just got the thing, and I'm trying to get it running good before my friend gets it.
     
  6. reeser

    reeser 1/2 ton status

    Joined:
    Oct 8, 2001
    Posts:
    434
    Likes Received:
    0
    Location:
    Hayden Lake, ID
    Re: TBI 454... bad hesitation. Just doesn\'t \"open up\"

    why haven't you asked me????? /forums/images/graemlins/dunno.gif /forums/images/graemlins/dunno.gif /forums/images/graemlins/dunno.gif

    i just went through all of this with mine! i bet it is the MAP sensor, that is what solved mine after i replace EVERYTHING. also, go to schucks and they have a scanner you can use to run codes and figure it out the technical way. /forums/images/graemlins/waytogo.gif /forums/images/graemlins/peace.gif
     
  7. mountainexplorer

    mountainexplorer 1/2 ton status

    Joined:
    Nov 14, 2001
    Posts:
    4,903
    Likes Received:
    0
    Location:
    Spokane, Wa./Ione, Wa
    Re: TBI 454... bad hesitation. Just doesn\'t \"open up\"

    I guess I just forgot.

    Shouldn't you be in class right now?
     
  8. reeser

    reeser 1/2 ton status

    Joined:
    Oct 8, 2001
    Posts:
    434
    Likes Received:
    0
    Location:
    Hayden Lake, ID
    Re: TBI 454... bad hesitation. Just doesn\'t \"open up\"

    haha!!!
    well i'm finishing up a huge project due this afternoon. you got to have priorities in life!
     
  9. mountainexplorer

    mountainexplorer 1/2 ton status

    Joined:
    Nov 14, 2001
    Posts:
    4,903
    Likes Received:
    0
    Location:
    Spokane, Wa./Ione, Wa
    Re: TBI 454... bad hesitation. Just doesn\'t \"open up\"

    You must be in the library. I drove it past your house a bit ago and didnt see the truck.

    How much was the map sensor when you bought it?
     

Share This Page