Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

TBI 5.7 350 Timing?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by badfish4tail, Nov 14, 2005.

  1. badfish4tail

    badfish4tail 1/2 ton status

    Joined:
    Mar 1, 2005
    Posts:
    1,684
    Likes Received:
    1
    Location:
    Long Beach
    Hey hopefully someone can help me out with this. I am working on my 1991 Blazer which has a 5.7 350 with TBI. I was wondering what the timing needs to be set at and anyone know were to look for the wire to unplug. Had a buddy (onlychevy6) check the timing with his gun and showed my timing being at 12*. Thanks for any help you can offer...
    Ialso posted this in the garage.
     
  2. jays68yak

    jays68yak 1/2 ton status

    Joined:
    Feb 27, 2003
    Posts:
    973
    Likes Received:
    2
    Location:
    Gilroy, CA
    Next to the firewall bulkhead connector, tan wire with a brown strip. Or it could be under the dash.
     
  3. kram

    kram Registered Member

    Joined:
    May 29, 2005
    Posts:
    54
    Likes Received:
    0
    Location:
    Edison n.j.
    88 is zero, large indent on pointer.
     
  4. sweetk30

    sweetk30 professional hooker Premium Member

    Joined:
    Nov 1, 2004
    Posts:
    25,528
    Likes Received:
    527
    Location:
    horseheads , ny 14845
    both are correct. tbi is zero. with wire unpluged before start up. and when done shut off and replug wire in and fire and make sure check engine light goes out.
     
  5. trikstark5

    trikstark5 1/2 ton status

    Joined:
    Feb 17, 2004
    Posts:
    169
    Likes Received:
    0
    Location:
    usa
    Disconnect the tan wire by the firewall with the truck not running. Start the truck, and set the timing to 0*. Shut the truck off and rehook up tan wire. That should pretty much do it.
     

Share This Page