Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

TBI fuel sending unit with old gauge???

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by BigJohnson, Apr 21, 2004.

  1. BigJohnson

    BigJohnson 1/2 ton status

    Joined:
    Jan 22, 2001
    Posts:
    207
    Likes Received:
    0
    Location:
    AL
    I am doing a TBI swap on my 82 K5 and I am swaping in a EFI tank with a new sending unit and in the tank pump. Will the EFI sending unit work with my 82 fuel gauge? The EFI sending unit I have only has two wires and they go to the pump and the float. My 82 sending unit had two wires and a ground wire. If this will work how do I hook up the wires?

    Thanks
     
  2. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,982
    Likes Received:
    191
    Location:
    Roy WA
    On the TBI sending unit/wiring I got, there were three wires. One is the gauge wire, one is the power wire for the pump, and there is still a ground. (yes it will work with the older gauges)

    I can't remember how the ground is attached to the sender (might be just like the old ones, the ground wire is pushed onto a pin on top of the sender) but I do remember that I moved where it bolts to the frame from the passenger side of the crossmember to the drivers side frame rail...that may have been the shorter distance, but whether it was less distance or not, it was much easier to get at. /forums/images/graemlins/smile.gif
     
  3. BigJohnson

    BigJohnson 1/2 ton status

    Joined:
    Jan 22, 2001
    Posts:
    207
    Likes Received:
    0
    Location:
    AL
    Thanks Dyeager535! I don't have the parts in front of me and couldn't remeber but yes the TBI unit does have 3 wires. I am glad I don't need anything else...I have already blown my budget for this project /forums/images/graemlins/ooo.gif

    I've still got to search through my 95' factory manual to find out what the 1227427 PCM used for the park/nuetral signal. That and the VSS are the only things I have left in my harness to finish /forums/images/graemlins/laugh.gif The newer VSS ruled out the guage mounted optical sensor...bummer. Still don't know what I am going to do about that. I think a 4L60E is in my future.
     
  4. realsquash

    realsquash 1/2 ton status

    Joined:
    Jul 12, 2000
    Posts:
    778
    Likes Received:
    0
    Location:
    SE WI
    I'll second that the sender will work with your gauge. An 87 sender worked on my 77 also. What are you worried about with the VSS? You can buy a VSS that goes between the speedo cable and t-case (mounts right on the tcase) or it's possible to run w/o one at all.

    Andy
     

Share This Page