Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

TBI injector not firing

Discussion in 'The Garage' started by Jonny-K5, Aug 28, 2005.

  1. Jonny-K5

    Jonny-K5 1/2 ton status

    Joined:
    May 27, 2003
    Posts:
    1,654
    Likes Received:
    0
    Location:
    SoCal
    just installed my old TBI thats been sitting in a box for two years. one injector is stuck closed. anyway i can unstick it?
     
  2. HarryH3

    HarryH3 1 ton status Author

    Joined:
    May 31, 2000
    Posts:
    10,384
    Likes Received:
    2
    Location:
    Georgetown, TX
    Remove it, look in the business end and find the end of the pintle (the pin that the coil pulls open to spray fuel. Press straight in on the pintle with a flat-tipped punch. You'll feel a small click when it finally opens. Reinstall.

    Three of the injectors were stuck closed when I installed the 'vette TPI motor in my '75. It had been sitting for over a year (and GM later recalled the '87 injectors for sticking problems). The procedure got all of them working just fine. :cool1:
     
  3. Jonny-K5

    Jonny-K5 1/2 ton status

    Joined:
    May 27, 2003
    Posts:
    1,654
    Likes Received:
    0
    Location:
    SoCal
    thanks for the reply. i decided to just replace it since the parts stores where closing and i didnt want to be stranded. guess maybe i'll have a spare now :D
     

Share This Page