Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

TBI intake manifold

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 90K5, Mar 29, 2003.

  1. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    just pulled it off...the back two water passages were blocked off, had a foil looking thing over them...what was that? Also i think its the worst feeling in the world when your on the last bolt, seal already broken and you find a vac. line coming off the throttle body going nowhere...when a vac leak somewhere was the problem
     
  2. Thunder

    Thunder 3/4 ton status

    Joined:
    Jul 20, 2000
    Posts:
    8,946
    Likes Received:
    1
    Location:
    Northeast Nevada
    Sorry to hear you went thru all that work and found the vac line off. If it is the one in the back of the throttle body it is suposed to go the MAP sensor.
    I know there is a reason for those back water passages to be blocked off but I cant rember why.
    Good luck getting it back togather and running good
     
  3. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    Re: TBI intake manifold - need bolt torque

    anyone know what to torque intake manifold bolts to? chiltons is a piece of crap
     
  4. 55Willy

    55Willy 3/4 ton status

    Joined:
    Jun 2, 2001
    Posts:
    9,946
    Likes Received:
    0
    Location:
    Keizer, Or
    Re: TBI intake manifold - need bolt torque

    35 pounds
    and the back two passages are surpose to be blocked.
     
  5. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    yeah i figureed that about the passages, my new gaskets had them block too, so i just put them on. Also found the torque specs in the manual they were just really hidden. Thanks though, hopefully everything will go back right, and i wont fall asleep doing it.
     
  6. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    finally got it together...need to tim it, but will do tomorrow...er later today i guess..it actually runs!!!!!!!!!!
     
  7. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    Well, that accomplished nothing. Still running like crap, actually even worse lately...the map sensor isnt bad, borrowed one off a friends truck and it did the same thing. Running out of ideas here
     
  8. the professor

    the professor 1/2 ton status

    Joined:
    Feb 6, 2003
    Posts:
    130
    Likes Received:
    0
    Not sure what you mean by "runnig like crap"
    --
    Idle, cruise, accelertion..??
    --
    Idle, bad temp sensor--O2 sensor--TPSensor..Leaking egr..bad injector nozzle
    --
    Everywhere...bad wires...plugged cat...bad injector nozzle
    --
    Did anyone check for codes..."might" be enlightening..
    --
    /forums/images/graemlins/cool.gif /forums/images/graemlins/truck.gif
     
  9. BigBurban350

    BigBurban350 1/2 ton status

    Joined:
    Jun 9, 2002
    Posts:
    711
    Likes Received:
    0
    Location:
    Michigan
    Re: TBI intake manifold - need bolt torque

    [ QUOTE ]
    anyone know what to torque intake manifold bolts to? chiltons is a piece of crap

    [/ QUOTE ]

    I hate chiltons, they dont have any specs and anything to hard to explain they tell you to seek a professional.

    /forums/images/graemlins/usaflag.gif /forums/images/graemlins/burb.gif /forums/images/graemlins/usaflag.gif
     
  10. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    sorry about that, it was in another post...basically surging when hot and at lower rpms...not when cold though
    rebuilding the TC tomorrow since i tried cleaning the injectors today and its leaking...injectors spray better though
     

Share This Page