Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

TH350 Problems

Discussion in 'The Garage' started by txfireman110, Apr 22, 2004.

  1. txfireman110

    txfireman110 1/2 ton status

    Joined:
    Nov 1, 2003
    Posts:
    294
    Likes Received:
    0
    Location:
    San Angelo, TX
    Any idea what would cause a TH350 to spew fluid out the dipstick tube? Also, what would cause it to not be able to get it in park, and have to hold it in reverse? I have allready checked the linkage, and with it disconnected, you can manually go through all positions on the tranny.

    PS-this is in a friend's 83 K5
    Thanks
     
  2. big83chevy4x4

    big83chevy4x4 3/4 ton status

    Joined:
    Mar 22, 2002
    Posts:
    6,587
    Likes Received:
    0
    Location:
    Sheridan, Michigan
    check the vent tube. most likely its plugged.

    is the linkage adjusted correctly? loose maybe /forums/images/graemlins/dunno.gif
     
  3. txfireman110

    txfireman110 1/2 ton status

    Joined:
    Nov 1, 2003
    Posts:
    294
    Likes Received:
    0
    Location:
    San Angelo, TX
    Checked the Linkage allready, tried, but it is like the linkage won't move through the full range of motion? /forums/images/graemlins/dunno.gif
     
  4. tweek

    tweek 1/2 ton status

    Joined:
    Aug 13, 2003
    Posts:
    353
    Likes Received:
    0
    Location:
    montgomery, ny
    does the truck have a body lift???maybe someone didn't weld in the extension rod properly and your not getting your full range of motion.........just a thought
     
  5. txfireman110

    txfireman110 1/2 ton status

    Joined:
    Nov 1, 2003
    Posts:
    294
    Likes Received:
    0
    Location:
    San Angelo, TX
    No, there is no Body lift on this truck.

    ***Where is this elusive "vent tube"? I can't find it***
     
  6. big83chevy4x4

    big83chevy4x4 3/4 ton status

    Joined:
    Mar 22, 2002
    Posts:
    6,587
    Likes Received:
    0
    Location:
    Sheridan, Michigan
    its on the very top of the tranny, just behind where the bellhousing connects to the main body.

    if the tranny will get hit every gear, with it disconected but won't when you hook it up then its in the linkage.

    with the linkage disconected, can you move the column selector to every position?
     

Share This Page