Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

th400 woes

Discussion in 'The Garage' started by tomseviltwin, Feb 20, 2005.

  1. tomseviltwin

    tomseviltwin 1/2 ton status

    Joined:
    Dec 23, 2001
    Posts:
    2,065
    Likes Received:
    0
    Location:
    Utah
    Ok, I wish I was smarter about this stuff. The th400 behind my 1990 2wd Suburban feels like it is searching for a lower gear. It doesn't seem to be slipping but the engine revs as it downshifts for no reason. Also seems to be "tripping" into a higher gear. when it shifts into 3rd. Is there any easy fix to pursue or is the tranny just giving out. I just bought the Burb a week ago.
     
  2. goldwing2000

    goldwing2000 Guest

    Check the downshift switch and the vacuum line. Those are always likely candidates.
     
  3. Ryan B.

    Ryan B. 3/4 ton status GMOTM Winner

    Joined:
    Jul 18, 2001
    Posts:
    5,693
    Likes Received:
    0
    Location:
    CA
    tripping into higher gear? just third? what do you mean.. like a flare in the shift, kind of a double shift where you can feel it slip and then finally engage?
     
  4. tomseviltwin

    tomseviltwin 1/2 ton status

    Joined:
    Dec 23, 2001
    Posts:
    2,065
    Likes Received:
    0
    Location:
    Utah
    It's like it holds on to 2nd gear too long and then kind of clunks into drive. I've replaced alot of vacume line on this truck already. I'll look into the Modulator line? Is that the only thing that "kicks down?"
     
  5. tomseviltwin

    tomseviltwin 1/2 ton status

    Joined:
    Dec 23, 2001
    Posts:
    2,065
    Likes Received:
    0
    Location:
    Utah
    Is the downshift switch on the TBI intake somewhere? I'm thinking there's some kind of vacume problem as it isn't always acting up.
     
  6. fatbob

    fatbob 1/2 ton status

    Joined:
    Jul 3, 2003
    Posts:
    420
    Likes Received:
    0
    Location:
    Phoenix, Az
    I'm working on the same problem on my 88. It wants to run to the top of the gear before it will shift, just as if I had the gas pedal floored and the kickdown switch ativated.

    What I know is the kickdown is electrically activated. On my carbed '77 the switch is on the gas pedal bracket. when the pedal is depressed more than halfway it hits an arm on the switch.
    :what: What I dont know is where it is located on TBI trucks. Mine is missing from the gas pedal. And I'm not sure if T400's came in a lockup version like the T350's, which would have an extra wire running to the tranny.
    Also, I believe most gas pedal brackets have the hole for the switch no matter what tranny was used, so its easy enough to put one in.
    Good luck
    Bob
     

Share This Page