Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

the 71 cooling system wont build up pressure

Discussion in 'The Garage' started by R72K5, Apr 9, 2005.

  1. R72K5

    R72K5 Banned

    Joined:
    Mar 5, 2001
    Posts:
    8,905
    Likes Received:
    0
    Location:
    central IL
    ok i ran the 71 today til it was way plenty hot, drove it around the neighborhood and all that good stuff, after got brakes going again and axle and trans filled and all that, you know how all that goes,


    i noticed that the cooling system has no pressure in it at all,

    everything was hot, hoses, radiator, engine, all of it, was fine

    was just no pressure felt in hoses, soft, easy to collapse

    what might be the problem ?

    truck sat for many years not running

    today was the first time it saw pavement and drove on it and all that... for mAny years, since 96 or maybe a little earlier possibly it looks like, from the research ive done


    so,,,


    thanks
     
  2. 4X4HIGH

    4X4HIGH 1 ton status Premium Member GMOTM Winner

    Joined:
    Dec 14, 2001
    Posts:
    22,059
    Likes Received:
    69
    Location:
    Pleasanton, CA.
    Replace the radiator cap. That is what allows pressure to build up, most caps are 15-16 lbs. This should cure your problem. :thumb:
     
  3. R72K5

    R72K5 Banned

    Joined:
    Mar 5, 2001
    Posts:
    8,905
    Likes Received:
    0
    Location:
    central IL
    ohhhhhh yeaaaaah

    forgot about cap
    yep i bet it is whats wrong too! its old and rotted, humm

    or i hope thats what the deal is, :D


    cool thanks :thumb:
     

Share This Page