Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

The Kenwood took a sh!t.

Discussion in 'Audio' started by UseYourBlinker, Apr 1, 2003.

  1. UseYourBlinker

    UseYourBlinker 1 ton status

    Joined:
    Jun 7, 2000
    Posts:
    11,117
    Likes Received:
    0
    Location:
    .
    Here's what I had

    I just got the new Alpine 9811,and another amp. The Kenwwod only lasted 4 months. It didn't want to play CD's anymore. /forums/images/graemlins/ignore.gif
     
  2. 83ZZ502_Jimmy

    83ZZ502_Jimmy 1/2 ton status

    Joined:
    Feb 7, 2001
    Posts:
    3,103
    Likes Received:
    0
    Location:
    Richmond, VA
    Sorry to hear that. Hope you have better luck with the Alpine.

    John [​IMG]
     
  3. Cmoe

    Cmoe 1/2 ton status

    Joined:
    Feb 19, 2000
    Posts:
    2,884
    Likes Received:
    0
    Location:
    Mesa,AZ
    That s*cks!
     
  4. Z3PR

    Z3PR Banned

    Joined:
    Mar 30, 2002
    Posts:
    19,217
    Likes Received:
    0
    Location:
    Everywhere
    My bro's Kenwood 9017 crapped out 2 months after he got it. He bought it used, so what can ya do ??? He's wants to get a top of the line Alpine, Clarion, or JVC sometime this summer.
     
  5. AzzKicker

    AzzKicker 1/2 ton status

    Joined:
    Jul 28, 2002
    Posts:
    265
    Likes Received:
    0
    Location:
    Edinburg, Tx
    My dad had those kenwoods with the MASK face and it too crapped out. Turned out that with so much closing and opening the ribbon that controls the display and everything tore or broke. A repair shop replaced it for like 50 bucks and it works now.
     

Share This Page