Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Think my tranny's screwed up

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by deek, Jun 23, 2003.

  1. deek

    deek 1/2 ton status

    Joined:
    May 6, 2003
    Posts:
    142
    Likes Received:
    0
    Location:
    Great Bend, KS
    Think my tranny\'s screwed up

    with the shifter all the way up, I can still roll my blazer down the driveway. would it be that the linkage is outta wack?
     
  2. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    Re: Think my tranny\'s screwed up

    Probably just the linkage. If you crawl under the truck, you can disconnect the shift linkage, and manually work the bracket on the side of the tranny. Each gear should give you a solid sound as it detents into each gear. Once you get it all the way into park, you can check and see if that fixed the problem.

    IIRC, there is no way for park NOT to work short of external problems, unless the internal rod is ruined or not there somehow. The only internal piece I see being "prone" to failure is the spring on the park assembly and even if it failed, it would keep the tranny in park, not let it roll.
     
  3. DOCKAWI650

    DOCKAWI650 Registered Member

    Joined:
    Sep 29, 2002
    Posts:
    61
    Likes Received:
    0
    Location:
    Gboro, NC
    Re: Think my tranny\'s screwed up

    Could be the transmission...i had a similar problem with a old mercedes. put it in park and it would start rolling and you could hear the transmission pumping and the gears not catching. It could be the tranny or linkage...

    -Doc
     
  4. blasterD

    blasterD 1/2 ton status

    Joined:
    May 24, 2003
    Posts:
    410
    Likes Received:
    0
    Location:
    Anchorage Alaska
    Re: Think my tranny\'s screwed up

    I think you probably just need to adjust the linkage. Have you been wheeling lately and twisted up the frame? Put some chocks under the tires and crawl under. See if you can disconnect the linkage and put it in park by hand. If this doesn't work you may have some serious tranny issues.
     
  5. imiceman44

    imiceman44 1 ton status

    Joined:
    Aug 5, 2002
    Posts:
    15,160
    Likes Received:
    1
    Location:
    Sacramento, CA
    Re: Think my tranny\'s screwed up

    [ QUOTE ]
    Probably just the linkage. If you crawl under the truck, you can disconnect the shift linkage, and manually work the bracket on the side of the tranny. Each gear should give you a solid sound as it detents into each gear. Once you get it all the way into park, you can check and see if that fixed the problem.

    IIRC, there is no way for park NOT to work short of external problems, unless the internal rod is ruined or not there somehow. The only internal piece I see being "prone" to failure is the spring on the park assembly and even if it failed, it would keep the tranny in park, not let it roll.

    [/ QUOTE ]

    If it's not external, it could be the park pin.
    It's a very whimppy pin, I don't know how they trust this pin to hold the truck but it works if you don't jam it into park while you are roling stil.
     

Share This Page