Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Throttle Response

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by ironmikek5, Aug 15, 2001.

  1. ironmikek5

    ironmikek5 1/2 ton status

    Joined:
    May 31, 2001
    Posts:
    145
    Likes Received:
    0
    Location:
    Massachusetts
    83 GMC Jimmy w/350, Quadrajet, have replaced fuel pump, filter, lines, cap, rotor, plugs, wires. It ran rough before, runs much better now, but I'm still having trouble under load. If I accelerate hard, the engine stumbles, but if I ease back a little on the pedal, she takes right off.

    I've got a rebuild kit for the Quad sitting on my bench, taunting me. Before I rip it off and rebuild it, I'm wondering if there isn't another potential cause/solution.



    <font color=red>"Oil? That's not my oil...that was there before" </font color=red>[​IMG]
     
  2. CaptCrunch

    CaptCrunch 1/2 ton status

    Joined:
    Feb 2, 2001
    Posts:
    3,596
    Likes Received:
    1
    Location:
    Minnesota
    Well it is kinda hard to say not being there, but sounds like a carb problem. Maybe an accelerator pump problem. Is it hard to start cold? A carb rebuild probably will cure what ales ya!

    -Mikey
    1987 Chevy K5 Blazer- 350 TBI
    <a target="_blank" href=http://www.geocities.com/milnerlives_2000/blazer.htm>http://www.geocities.com/milnerlives_2000/blazer.htm</a>
     
  3. mudhog

    mudhog THEGAME Staff Member Super Moderator

    Joined:
    Nov 6, 2000
    Posts:
    17,899
    Likes Received:
    2
    Location:
    portland oregon
  4. ironmikek5

    ironmikek5 1/2 ton status

    Joined:
    May 31, 2001
    Posts:
    145
    Likes Received:
    0
    Location:
    Massachusetts
    It starts on the first turn when cold, and I figured it is carb related, I'm just doing the caveman/fire fear thing, but I guess the end result is that I rebuild the quad.

    <font color=red>"Oil? That's not my oil...that was there before" </font color=red>[​IMG]
     

Share This Page