Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

totally frustrated - can't figure out why I can't get spark...

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by solowookie, May 4, 2002.

  1. solowookie

    solowookie 1/2 ton status

    Joined:
    Mar 31, 2001
    Posts:
    3,880
    Likes Received:
    0
    Location:
    Wyoming
    totally frustrated - can\'t figure out why I can\'t get spark...

    ok guys...

    I have no idea how these two are related, but they seem to be.

    I have the custom VDO gauge cluster in my 89 k5 right. well there are a few things I have never hooked up, and wanted to get taken care of. I have never had my caution light hooked up, and my bright / dim indicator.

    well the other night I was coming home from fishing, and I blew a fuse which killed my gauge lights. well I temp hooked it up with the power cable to my gauges so that when the ignition came on the dash lights would come on too.

    well I disconnected everything to fix all this, and disconnected my parking brake indicator, and 4x4 indicator permanently. well I got everything fixed, and I connected up all the gauges to test everything (blinkers, bright/dim, all gauges etc.). everything seemed to test out fine.

    well everything was fine until I went to start the beast, and for some reason I can't get spark. what in the world would keep a TBI from getting spark? I'm not even sure where to begin.
     
  2. 95 Silverado

    95 Silverado 1/2 ton status

    Joined:
    Nov 9, 2001
    Posts:
    467
    Likes Received:
    0
    Location:
    Central PA
    Re: totally frustrated - can\'t figure out why I can\'t get spark...

    one thing comes to mind, if your gauge cluster has a tach in it, the tach signal wire is connected to the ignition circuit. check to be sure something didn't get disconnected or grounded out to kill the spark.
     
  3. RESTORE89

    RESTORE89 1/2 ton status

    Joined:
    Jan 31, 2001
    Posts:
    548
    Likes Received:
    0
    Location:
    CHAS SC
    Re: totally frustrated - can\'t figure out why I can\'t get spark...

    when you turn on the key the ignition switch sends the power to the coil. do you have power at the coil? if not it must be in the wires you unhooked to fix your gauges. if something is grounding out, you could try removing all the non essential fuses and then try cranking.
    electrical trob shooting is never fun
    keep us posted
    good luck
    chris
     
  4. solowookie

    solowookie 1/2 ton status

    Joined:
    Mar 31, 2001
    Posts:
    3,880
    Likes Received:
    0
    Location:
    Wyoming
    Re: totally frustrated - can\'t figure out why I can\'t get spark...

    yea it does - but I already double checked that. I'm assuming the spark is controlled by the computer. this strange part is that all the gauges have 2 senders in the vehicle; one for the computer, and one for the instrument cluster.

    I've ran this vehicle with no gauges in it, and nothing hook up. I got the wiring diagrams outta the hayes manual, and looked up all the wires in the area I had dealth with, and I cannot find the problem anywhere.
     
  5. solowookie

    solowookie 1/2 ton status

    Joined:
    Mar 31, 2001
    Posts:
    3,880
    Likes Received:
    0
    Location:
    Wyoming
    Re: totally frustrated - can\'t figure out why I can\'t get spark...

    do you happen to know what color of wire goes from the ignition to the coil?
     
  6. RESTORE89

    RESTORE89 1/2 ton status

    Joined:
    Jan 31, 2001
    Posts:
    548
    Likes Received:
    0
    Location:
    CHAS SC
    Re: totally frustrated - can\'t figure out why I can\'t get spark...

    no, but you can look at the coil and i think there are only 2-3 wires there, i think a white wire is the tach hookup, but dont quote me on that. just look at the coil and trace teh wires from there back
    chris
     
  7. solowookie

    solowookie 1/2 ton status

    Joined:
    Mar 31, 2001
    Posts:
    3,880
    Likes Received:
    0
    Location:
    Wyoming
    Re: totally frustrated - can\'t figure out why I can\'t get spark...

    thanks for the F.Y.I ... I'll take it up in the morning, and see if I can get this figured out.
     
  8. Sparky

    Sparky 1/2 ton status

    Joined:
    Aug 20, 2000
    Posts:
    423
    Likes Received:
    0
    Location:
    San Antonio(summer) Texas A and M (school year)
    Re: totally frustrated - can\'t figure out why I can\'t get spark...

    Did your truck ever have an alarm in it? I blew a relay out in the remainders of an alarm that was there from a previous owner. I just found it by starting at the key with a volt meter and working my way out untill I lost voltage. I think my back still hurts from being under that dash for so long. Took me about an hour from the time i started looking to the time I was done.

    If you think it is a computer problem, disconnect the battery for a few minutes and then try it again. If the computer isnt screwed it will reset itself and work again.

    Ryan
     
  9. 4X4HIGH

    4X4HIGH 1 ton status Premium Member GMOTM Winner

    Joined:
    Dec 14, 2001
    Posts:
    22,060
    Likes Received:
    69
    Location:
    Pleasanton, CA.
    Re: totally frustrated - can\'t figure out why I can\'t get spark...

    If you have power to your coil but don't have any spark then you seem to have a bad ignition module in the distributor. Replace the module and it should fix it. By the way, it is a good thing to keep a spare in the glove box as this is a common problem with GM vehicles.
     
  10. solowookie

    solowookie 1/2 ton status

    Joined:
    Mar 31, 2001
    Posts:
    3,880
    Likes Received:
    0
    Location:
    Wyoming
    Re: totally frustrated - can\'t figure out why I can\'t get spark...

    well guys - I am more frustrated then ever.

    there is spark coming from the ignition, but there is a white wire, and a red wire that connected into coil. one is getting power, and the other isn't. there doesn't seem to be any spark coming from the coil.

    when I put this new engine in I put a MSD blaster coil II in this so I'm going to try the old coil as my next move. I don't believe that is going to do anything though.

    I'm still betting that there is a computer wire somewhere that isn't getting activated correctly, but I'm not sure exactly where & how to find that.

    anybody have any new suggestions?
     
  11. Sparky

    Sparky 1/2 ton status

    Joined:
    Aug 20, 2000
    Posts:
    423
    Likes Received:
    0
    Location:
    San Antonio(summer) Texas A and M (school year)
    Re: totally frustrated - can\'t figure out why I can\'t get spark...

    If you are getting power to the coil, its probably the ignition module. If you take the cap and roter off there will be a couple of screws holding down the piece that has the three wires coming out of the distributor. Take those off and out comes the ignition module as well as the capacitor. Just pull the two pieces apart (they will be connected with male and female wire connectors) Take the piece without any wires hanging on it (ignition module) to the parts store and have them test it. They just plug it into a little machine and tell you if its good or bad.

    Ryan
     
  12. solowookie

    solowookie 1/2 ton status

    Joined:
    Mar 31, 2001
    Posts:
    3,880
    Likes Received:
    0
    Location:
    Wyoming
    Re: totally frustrated - can\'t figure out why I can\'t get spark...

    already changed the ingition module...

    got the problem fixed though, and I was 100% wrong!!! it was the coil.

    go figure I have 700 miles on a new MDS blaster II coil, and it is bad! /forums/images/icons/mad.gif I don't know what the warrantee is on these, if there is one, but I think it's going to get replaced with and accell. I know a lot of people don't like accell, but hey I ran one before, and I liked it a lot. the MSD coil's reliability wasn't real great! /forums/images/icons/mad.gif/forums/images/icons/crazy.gif
     
  13. Zepplin

    Zepplin 1/2 ton status

    Joined:
    Aug 29, 2000
    Posts:
    920
    Likes Received:
    0
    Location:
    Bay City, MI 48706
    Re: totally frustrated - can\'t figure out why I can\'t get spark...

    Last Friday I saw on this board to NOT use the Blaster 2 coil from MSD. They had the same early failure problems. They suggested using the MSD SS Coil instead.
     

Share This Page