Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

TPS not bad, check engine light still coming on...

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 90K5, Apr 6, 2002.

  1. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    My check engein light will still come on randomly, always at highway speeds. I have replaced the Oxygen Sensor and borrowed a TPS off a 90 PU that doesn't have this problem, and it still happens, and my TPS is fine on the other truck...any ideas what could be wrong with it?

    BTW, is it possible this is because of my Hypertech Thermomaster chip? I am supposed to run Premium, but always run regular. I have heard this will make the computer retard the timing, so I think I will take it back to stock...hopefully that will help...any more ideas?
     
  2. Chris Demartini

    Chris Demartini 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    2,406
    Likes Received:
    1
    Location:
    Dumont NJ 07628
    <font color=blue>Run premium and see what code is in the computer. Throwing random parts at it will not turn the light off.
     
  3. Stoopalini

    Stoopalini 1/2 ton status

    Joined:
    Oct 17, 2000
    Posts:
    999
    Likes Received:
    0
    Location:
    Austin, Texas
    Have you looked into WinALDL yet? it's a freeware program that will allow you to connect a computer to your ECM and see what's going on with the light.

    Check it out <a target="_blank" href=http://srd.yahoo.com/goo/winALDL/1/T=1018203632/F=fa66752e0740c6cad7d50831e583cea5/*http://w1.601.telia.com/~u60113744/software/winaldl/winaldl.htm>WinALDL Home Page</a>

    I use it to diagnose my '92 TBI Camaro, and it has been invaluable.

    Good luck,

    Thomas.
     
  4. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    I put the stock chip back in, and disconnected the battery for a while and it still does it. I may try that FreeWin program...where can I get it?
     
  5. MudRebel350

    MudRebel350 1/2 ton status

    Joined:
    May 20, 2000
    Posts:
    324
    Likes Received:
    0
    Location:
    N.J.
    If the light comes on at highway speeds i can guarantee that it is your egr valve or something to do with the egr valve whether its a bad sensor or the valve itself, if you know how to do flash codes with the Service engine soon light, the egr code is code 32.

    Justin
     
  6. Stoopalini

    Stoopalini 1/2 ton status

    Joined:
    Oct 17, 2000
    Posts:
    999
    Likes Received:
    0
    Location:
    Austin, Texas
    Just click the link in my previous post to go to the WinALDL home page. You'll need to make an interface cable to use it. The parts cost about $10 from radio shack, and there are directions on the web page.

    Thomas.
     
  7. jmd

    jmd Registered Member

    Joined:
    Oct 25, 2001
    Posts:
    63
    Likes Received:
    0
    Location:
    Phoenix, Aridzona
    What code is it setting??? That's all you need to effectively track it down. EGR is usually highwayish though. Cleaning the passages or replacing the solenoid are things to look into *if* it sets an EGR code.

    I am ordering a cable for winaldl this week. I already have a scanner that does 99% of GM / Mopar/ FoMoCo but I have a laptop and want to try winaldl on my MAF TPI and my CCC and a friends SD TPI.

    The guy I contacted on the cables he sells will make me one where the 10k resistor is switchable so I can use it on the SD and the MAF....

    Matthew
     
  8. CaptCrunch

    CaptCrunch 1/2 ton status

    Joined:
    Feb 2, 2001
    Posts:
    3,596
    Likes Received:
    1
    Location:
    Minnesota
    Link the ALDLpins and do the cheap man's scanner and find out what code it is setting instead of chasing a bunch of could be's and might be's. I do agree it sounds a lot like an EGR. I would take it off and clean it out real good. Make sure it works and the plunger moves and reinstall.
     
  9. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    The light goes off as soon as I turn off the ignition, so everytime I try to check the codes I get nothing.
     
  10. Stock88Jimmy

    Stock88Jimmy Newbie

    Joined:
    Apr 9, 2002
    Posts:
    1
    Likes Received:
    0
    This may or may not help, but I get a Check Engine light usually at sustained highway speed. I ran the code and looked it up on ALLDATA and it said that the code may occur when the exhaust has been modified.
     
  11. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    I wonder how modified it has to be for that? I have a Flowmaster and a Catco cat on mine....
     
  12. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    I wonder how modified it has to be for that? I have a Flowmaster and a Catco cat on mine....
    Took it out on the freeway and drove it hard, and the light didn't come on, hopefully cleaning the EGR Valve helped it.
     
  13. Seventy4Blazer

    Seventy4Blazer 3/4 ton status

    Joined:
    Apr 21, 2001
    Posts:
    5,634
    Likes Received:
    0
    Location:
    Escondido, CA
    get a carb set up. then when smog time comes up put it all back on and go.
    grant
     
  14. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    Its actually about smog time now, and I have no desire to have a carb....i think its fixed anyway.
     
  15. chris672

    chris672 1/2 ton status

    Joined:
    Jan 25, 2002
    Posts:
    554
    Likes Received:
    0
    Location:
    LODI, CA
    Was it the EGR because I've had the same prob. for awhile and have been just ignoring it.
     

Share This Page