Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

trailer light problems

Discussion in 'Tow & Trailer' started by fixmy59bug, Mar 6, 2007.

  1. fixmy59bug

    fixmy59bug Registered Member

    Joined:
    Feb 28, 2006
    Posts:
    88
    Likes Received:
    0
    Location:
    Riverside, Ca
    Recently I had to buy a 5x8 utility trailer for some stuff I was hauling. I bought the adapter for my 89 suburban to plug in the trailer harness and thuoght all was good. Not really, Late that night as I was driving home I was pulled over because the lights on the trailer were flickering off and on. After inspecting the harness on the side of the road, the officer was kind enough to let me go with a warning because we found out the adapter I just bought didn't have a dedicated ground prong. So essentially is it grounded through the tongue/hitch point. So when I got home, I took out the adapter and hardwired in a 4 pin (with ground) plug. Now my only problems are with the turn signals. I upgraded to an electronic flasher to cure the hyper blink. But now after a day of towing, I have no more turn signals. For some reason the fuse blows. If I disconnect the trailer and leave the electronic flasher in, There are no problems. It won't blow the fuse. Anyone have any ideas on why the trailer would blow the fuse after a day of towing? Thanks alot.
     
  2. dhcomp

    dhcomp 3/4 ton status Premium Member

    Joined:
    Mar 17, 2001
    Posts:
    9,862
    Likes Received:
    295
    Location:
    Truckee, CA
    Check your turn signal harness where it connects together under the hitch. I had this problem, and it was full of water.......replaced the trailer harness that hooked up there, and no more problems!
     

Share This Page