Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

tranny fluid in my antifreeze ?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by K5DRAGER, Sep 10, 2001.

  1. K5DRAGER

    K5DRAGER 1/2 ton status

    Joined:
    Jul 27, 2001
    Posts:
    1,164
    Likes Received:
    0
    Location:
    Momence, IL
    Tonight I was out taking off the front air dam and noticed that one of my radiator hoses was leaking. No big deal I just put a brand new radiator in about three weeks ago, so I figured just a loose clamp. So I popped the hood and tightened it and went to check the fluid level and to my surprise my overflow tank is at the correct level but is mostly oil. But I don't think its oil I think its tranny fluid cause it smells like it and is reddish in color, and the truck hasn't been hot and it was not that way before the new radiator. Has anyone else had problems with a new radiator?... By the way, yes its an auto and it has the heat exchanger. I checked the oil dipstick and it doesn't look milky. But neither does the tranny dipstick? Thanks for any help
     
  2. Can Can

    Can Can Pusher Man Staff Member Super Moderator

    Joined:
    Feb 17, 2000
    Posts:
    15,552
    Likes Received:
    136
    Location:
    Cochrane, Alberta, Canada
    It sounds like you got a bum radiator with a broken stock tranny cooler..........You said the overflow tank is full of "oil"- how does the coolant in the rad look?



    <font color=blue> MEAN DAD WITH TWO BAD KIDS<font color=blue>
     
  3. 83ZZ502_Jimmy

    83ZZ502_Jimmy 1/2 ton status

    Joined:
    Feb 7, 2001
    Posts:
    3,103
    Likes Received:
    0
    Location:
    Richmond, VA
    Yeah you've got a bad radiator. Take it back get a new one. But be SURE you CHANGE the tranny fluid. Water is bad in an auto.

    John

    '83 GMC Jimmy 4x4 ZZ4 Crate Motor
    '83 Chevy K20 Sand Drag Racer, 578 RWHP
    '94 Impala SS
    '01 Chevy 2500HD 4x4 w/8.1L & Allison Auto
     
  4. K5DRAGER

    K5DRAGER 1/2 ton status

    Joined:
    Jul 27, 2001
    Posts:
    1,164
    Likes Received:
    0
    Location:
    Momence, IL
    The coolant in the radiator has lots of small oil bubbles floating around in it. I sure hope thats what it is just bought all the stuff for regearing and getting ready for the lift. Not ready to do the motor just yet.
     
  5. 55Willy

    55Willy 3/4 ton status

    Joined:
    Jun 2, 2001
    Posts:
    9,946
    Likes Received:
    0
    Location:
    Keizer, Or
    yeah sounds like a bad radiator, your cooling system is swapping fluids.

    <font color=red>It's not what you drive, but what drives you</font color=red>( Or is it what you work on,lol)
    <font color=orange> 1955 willy's on a 1977 blazer chassis </font color=orange>
     

Share This Page