Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

tranny or TC vibes?

Discussion in 'The Garage' started by only 31s, Dec 2, 2005.

  1. only 31s

    only 31s 1/2 ton status

    Joined:
    Oct 5, 2004
    Posts:
    224
    Likes Received:
    0
    Location:
    mass
    hey guys,i have a lockout kit on my tranny[700r4]90 so the OD doesnt kick in until I want it . Its set at 50. always worked perfect{the tranny] recently basically overnight, when I got to 50 and my OD kicked in I got a heavy vibe,when i keep the same speed and maually put into D it works fine [no vibe] until i have to increase power [such as an incline on the highway] more peddle -vibes start to come back,but not as bad as OD.Its not mounts or ujoints -already checked -and i can get to 70 on flat highway in D without the vibe. any one have any exp w this? could it be my TC? thanks for any input.
     
  2. 89GMCSuburban

    89GMCSuburban 1/2 ton status

    Joined:
    Nov 15, 2001
    Posts:
    3,005
    Likes Received:
    0
    Location:
    Thornton, CO
    I had this happen, but only after I replaced the TC. Not sure why it happened, still does it... Does it have so much vibe that it doesn't accelerate? My 87 S10 did that. It sould get a bad vibe and wouldn't accelerate, let off the gas and punch it and it would go away...most of the time. Ended up being the TC coming apart internally and it screwed the trans.
     
  3. jekquistk5

    jekquistk5 Weld nekid Premium Member GMOTM Winner

    Joined:
    Jan 18, 2004
    Posts:
    11,023
    Likes Received:
    850
    Location:
    Pinckney, MI
    Same thing is up with my 90 I have the tranny out just waitin on a new T/c to get here.
     

Share This Page