Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

tranny prob

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by im_2gr82h8, Jan 23, 2003.

  1. im_2gr82h8

    im_2gr82h8 Registered Member

    Joined:
    Apr 4, 2001
    Posts:
    91
    Likes Received:
    0
    Location:
    federal way, washington
    I was actually gonna drive the truck again today, but it decided it didn't want to. It will go into 1st and 2nd gear fine, and shifts hard, but 3rd slips bad and when you put it back into park or N it will not go back into gear unless you turn the truck off. But if you turn it off and then back on it will go into gear. (turbo 350) I thought i was low on fluid, but the fluid is fine. Is my trany just shot or could it be something small like a filter? I also checked the vacume line and it was good.
    any thoughts are greatly appreciated
    Bill
     
  2. wheelin_willy

    wheelin_willy Registered Member

    Joined:
    Jan 23, 2003
    Posts:
    24
    Likes Received:
    0
    hey bill so you checked the fluid and its all right? not brown no bubbles or smell funny? if not i would check the filter first it can do weird things to the tranny. if those are ok then it is probably the governer. the gov. is easily reached through the inspection cover on the left rear of the tranny. pull it out and check the gear teeth and the weight springs for proper operation. if that doesnt work i would look into rebuilding it yourself. it isnt that hard and atsg sells a great manual for it. will
     
  3. imiceman44

    imiceman44 1 ton status

    Joined:
    Aug 5, 2002
    Posts:
    15,160
    Likes Received:
    1
    Location:
    Sacramento, CA
    What you are describing is a multitude of things and my bet is it's taking the craps. Slipping could happen from clogged filter but with the forward clutch wanting to engage when in neutral suggests otherwise.
    /forums/images/graemlins/frown.gif
     
  4. im_2gr82h8

    im_2gr82h8 Registered Member

    Joined:
    Apr 4, 2001
    Posts:
    91
    Likes Received:
    0
    Location:
    federal way, washington
    its not that the clutch will engage when in neutral, its that it will not go back into any gear ofter being put into park or neutral.
     
  5. im_2gr82h8

    im_2gr82h8 Registered Member

    Joined:
    Apr 4, 2001
    Posts:
    91
    Likes Received:
    0
    Location:
    federal way, washington
    Re: tranny prob *updated*

    I pulled the pan and the bottom had metal shavings. DOes this mean the tranny is blown? If so who would you suggest for a rebuild kit, thats not too expensive.

    thanks
     

Share This Page