Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

tranny problem

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by JerseyBlazer, May 27, 2002.

  1. JerseyBlazer

    JerseyBlazer Registered Member

    Joined:
    Mar 18, 2002
    Posts:
    28
    Likes Received:
    0
    Location:
    New Jersey
    took my k5 out today and found that it aint shifting properly. it shifts fine if i accellerate at over 1/4 throttle, but it gets stuck in gear at low throttle then shifts very hard, it does this in every gear, but it kicks down fine when i step on it. i checked the cable and the fluid and it all seems good. any ideas? its a 90 blazer with a 700r4.
     
  2. 88jimmyoungowner

    88jimmyoungowner 1/2 ton status

    Joined:
    Nov 20, 2001
    Posts:
    425
    Likes Received:
    0
    Location:
    georgia-rome
    i had the same problem. it was right after it was re-built. i took it back to the transmission shop and they fixed it. so maybe you could let a place look at it, and i think they said it was the cable of somesort. sorry about the lack of info, but hope it helps a little.
     
  3. tagurit

    tagurit Registered Member

    Joined:
    Mar 19, 2002
    Posts:
    25
    Likes Received:
    0
    Location:
    Nth E. Louisiana
    I've been told that on my th350, back rear right, there is a hose that can be pulled off a gold round thing (forgot name) and there is a screw in the hole of the gold round thing that adjusts the shifts. Too much and it won't shift at all so beware.

    after rebuild my tranny shifts rough if I get on it and that's what the guy said I could do.

    Take anything I say with a grain of salt.
     

Share This Page